#45976 [Opn->Asn]: SPL fails to load if simplexml is not loaded
| From: | johannes@php.net | Date: | Tue, 02 Sep 2008 23:49:40 +0000 |
| Subject: | #45976 [Opn->Asn]: SPL fails to load if simplexml is not loaded | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-128627@lists.php.net to get a copy of this message | ||
ID: 45976
Updated by: johannes@php.net
Reported By: development at domain51 dot com
-Status: Open
+Status: Assigned
Bug Type: SPL related
Operating System: OS X
PHP Version: 5.3CVS-2008-09-02 (CVS)
-Assigned To:
+Assigned To: helly
New Comment:
No, the behavior is wrong, the configure system should fail not create
an invalid build.
The question is: Should we enforce the availability of SimpleXML or
not? Without too much thinking I tend to say no, and thinking a bit more
I'm wondering if it makes sense to move SimpleXMLIterator from SPL to
SimpleXML then we could get rid of that dependency. Marcus, what's your
opinion on this?
Previous Comments:
------------------------------------------------------------------------
[2008-09-02 23:40:33] development at domain51 dot com
The problem is that SimpleXML should not be something that can be
disabled if it is required for SPL and SPL can not be disabled. This
will break all manner of debian packages that compile with
--disable-all
used.
------------------------------------------------------------------------
[2008-09-02 23:20:34] tularis@php.net
What exactly is bugged about this according to you?
SPL requires simpleXML, which you explicitly disallow. Seems pretty
straightforward to me? enable simpleXML and SPL will load just fine
again.
------------------------------------------------------------------------
[2008-09-02 16:52:18] development at domain51 dot com
Description:
------------
When the SimpleXML extension is not loaded, SPL fails to load.
Reproduce code:
---------------
$ ./configure --disable-simplexml && make && make install
$ php -v
Expected result:
----------------
PHP 5.3.0alpha3-dev (cli) (built: Sep 2 2008 11:09:22)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2008 Zend Technologies
Actual result:
--------------
PHP Warning: Cannot load module 'SPL' because required module
'simplexml' is not loaded in Unknown on line 0
PHP 5.3.0alpha3-dev (cli) (built: Sep 2 2008 11:09:22)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2008 Zend Technologies
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=45976&edit=1