#46114 [Opn->Bgs]: php_ldap loads for CLI but not for ISAPI
| From: | RQuadling at GMail dot com | Date: | Thu, 18 Sep 2008 14:31:28 +0000 |
| Subject: | #46114 [Opn->Bgs]: php_ldap loads for CLI but not for ISAPI | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-129086@lists.php.net to get a copy of this message | ||
ID: 46114
User updated by: RQuadling at GMail dot com
Reported By: RQuadling at GMail dot com
-Status: Open
+Status: Bogus
Bug Type: LDAP related
Operating System: Windows XP SP3
PHP Version: 5.3CVS-2008-09-18 (snap)
New Comment:
With thanks to Keisial via IRC. The problem was that Sambar Server
uses a different version of the SSL dlls.
Replacing them with the ones provided by PHP solved the issue.
A big thank you to Keisial.
Regards,
Richard Quadling.
Previous Comments:
------------------------------------------------------------------------
[2008-09-18 13:14:27] RQuadling at GMail dot com
Description:
------------
Using the same installation of PHP for CLI and ISAPI, with a
different ini file for each SAPI, but with extension=php_ldap.dll
present in both ini files.
At the command line php -m shows ldap.
But open starting my web server service (Sambar Server), I get the
error ...
PHP Startup: Unable to load dynamic library
'C:\PHP5\ext\php_ldap.dll' - The operating system cannot run %1.
phpinfo(); doesn't show ldap.
php --ri ldap shows ...
ldap
LDAP Support => enabled
RCS Version => $Id: ldap.c,v 1.161.2.3.2.11.2.18 2008/08/02 04:46:05
felipe Exp $
Total Links => 0/unlimited
API Version => 3001
Vendor Name => OpenLDAP
Vendor Version => 20319
Reverting to PHP 5.3.0-dev (June 12 2008 082017) and all works again.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=46114&edit=1