#44727 [Opn->WFx]: PHP installs but will not serve pages
ID: 44727
Updated by: jani@php.net
Reported By: stevenhunt_ at hotmail dot com
-Status: Open
+Status: Wont fix
Bug Type: IIS related
Operating System: Windows Vista Ultimate 64bit
PHP Version: 5.2.5
New Comment:
use the fastcgi instead.
Previous Comments:
------------------------------------------------------------------------
[2008-04-14 21:23:29] stevenhunt_ at hotmail dot com
Description:
------------
After successfully installing PHP i ryed to run a basic php info page
and got an extension error.
as best i can see this is due to it beinf a 32bit application but
changeing the proccess thread to allow 32 bit applications then causes a
service unavailable and crashed the process thread.
Reproduce code:
---------------
install and try PHP on vista ultimate 64bit edition.
Expected result:
----------------
phpinfo() to execute and pages to run
Actual result:
--------------
HTTP Error 500.21 - Internal Server Error
Handler "PHP-ISAPI" has a bad module "IsapiModule" in its module list
Module IIS Web Core
Notification ExecuteRequestHandler
Handler PHP-ISAPI
Error Code 0x8007000d
Requested URL http://localhost:80/info.php
Physical Path C:\inetpub\wwwroot\info.php
Logon Method Anonymous
Logon User Anonymous
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=44727&edit=1
Thread (2 messages)