Bug #18181: Apache refuses to start while loading libphp4.so if compiled with ldap support

From: Date: Fri, 05 Jul 2002 12:25:49 +0000
Subject: Bug #18181: Apache refuses to start while loading libphp4.so if compiled with ldap support
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-13214@lists.php.net to get a copy of this message
From: rajat.bhatia@motorola.com Operating system: Solaris 5.8 PHP version: 4.2.1 PHP Bug Type: Apache related Bug description: Apache refuses to start while loading libphp4.so if compiled with ldap support I compiled apache php module with mysql and ldap support. The following combinations were tried: Apache version 1.3.26 , 1.3.19 Mysql version 3.23.33 Netscape LDAP C SDK version 4.1 (SunOS5.6), 5.0 The httpd deamon refused to start and gave the following error. If I compile PHP without LDAP it works perfectly. Could you please correct this problem , or point me a workaround. I need ldap support in php for my work to go on. -- Error message follows ------------------------------- dummyuser@dummy:/usr/local/test_ap> ./bin/apachectl start Syntax error on line 241 of /usr/local/test_ap/conf/httpd.conf: Cannot load /usr/local/test_ap/libexec/libphp4.so into server: ld.so.1: /usr/local/test_ap/bin/httpd: fatal: relocation error: file /usr/local/test_ap/libexec/libphp4.so: symbol ldap_start_tls_s: referenced symbol not found ./bin/apachectl start: httpd could not be started dummyuser@dummy:/usr/local/test_ap> -- ldd report follows --------------------- dummyuser@dummy:/usr/local/test_ap/libexec> ldd libphp4.so libdl.so.1 => /usr/lib/libdl.so.1 libpam.so.1 => /usr/lib/libpam.so.1 libmysqlclient.so.10 => /usr/local/mysql/lib/mysql/libmysqlclient.so.10 libldapssl41.so => /usr/local/ldapcsdk4.14-SunOS5.6/lib/libldapssl41.so libplds3.so => /usr/local/ldapcsdk4.14-SunOS5.6/lib/libplds3.so libplc3.so => /usr/local/ldapcsdk4.14-SunOS5.6/lib/libplc3.so libnspr3.so => /usr/local/ldapcsdk4.14-SunOS5.6/lib/libnspr3.so libcrypt_i.so.1 => /usr/lib/libcrypt_i.so.1 libresolv.so.2 => /usr/lib/libresolv.so.2 libm.so.1 => /usr/lib/libm.so.1 libnsl.so.1 => /usr/lib/libnsl.so.1 libsocket.so.1 => /usr/lib/libsocket.so.1 libc.so.1 => /usr/lib/libc.so.1 libz.so.1 => /usr/lib/libz.so.1 libgen.so.1 => /usr/lib/libgen.so.1 libthread.so.1 => /usr/lib/libthread.so.1 libposix4.so.1 => /usr/lib/libposix4.so.1 libpthread.so.1 => /usr/lib/libpthread.so.1 libmp.so.2 => /usr/lib/libmp.so.2 libaio.so.1 => /usr/lib/libaio.so.1 /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1 -- Edit bug report at http://bugs.php.net/?id=18181&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=18181&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=18181&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=18181&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=18181&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=18181&r=support Expected behavior: http://bugs.php.net/fix.php?id=18181&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=18181&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=18181&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=18181&r=globals

« previous php.bugs (#13214) next »