#47099 [NEW]: PHP doesn't work with Apache 2.3
| From: | hjalle at sgh dot se | Date: | Wed, 14 Jan 2009 14:03:13 +0000 |
| Subject: | #47099 [NEW]: PHP doesn't work with Apache 2.3 | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-132857@lists.php.net to get a copy of this message | ||
From: hjalle at sgh dot se
Operating system: Debian
PHP version: 5.2.8
PHP Bug Type: Apache2 related
Bug description: PHP doesn't work with Apache 2.3
Description:
------------
This bug should have been worked out but it looks like it have not been
that. This is the former bug:
http://bugs.php.net/bug.php?id=39787&edit=2
When starting apache an error occurs. I used the latest PHP build:
php5.2-200901141130
Expected result:
----------------
Starting without problem
Actual result:
--------------
httpd: Syntax error on line 174 of /etc/apache23/conf/httpd.conf: Syntax
error on line 5 of /etc/apache23/conf.d/php-users.conf: Cannot load
/usr/lib/apache2/modules/libphp5apache23.so into server:
/usr/lib/apache2/modules/libphp5apache23.so: undefined symbol:
ap_get_server_version
--
Edit bug report at http://bugs.php.net/?id=47099&edit=1
--
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=47099&r=trysnapshot52
Try a CVS snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=47099&r=trysnapshot53
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=47099&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=47099&r=fixedcvs
Fixed in CVS and need be documented: http://bugs.php.net/fix.php?id=47099&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=47099&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=47099&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=47099&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=47099&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=47099&r=support
Expected behavior: http://bugs.php.net/fix.php?id=47099&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=47099&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=47099&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=47099&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=47099&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=47099&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=47099&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=47099&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=47099&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=47099&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=47099&r=mysqlcfg