Bug #15333 Updated: strndup access violation
| From: | nagender at sancharnet dot in | Date: | Sat, 06 Jul 2002 11:24:26 +0000 |
| Subject: | Bug #15333 Updated: strndup access violation | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-13301@lists.php.net to get a copy of this message | ||
ID: 15333
Updated by: nagender@sancharnet.in
Reported By: david@harksystems.com
Status: Critical
Bug Type: IIS related
Operating System: Windows 2000 Pro
PHP Version: 4.2.1
New Comment:
I am using latest Download from php.net i.e php 4.2.1 with IIS 5 on
Win2k Server running as ISAPI and always get the ACCESS VIOLATION ERROR
after 10-15 pages and then every single page. Even when i restart IIS ,
the problem doesn't go away. On rebooting, the events cycle again.
Gone thru all the messages, seems like nobody has much clue as to why
newer versions of php are giving this error and strange fact is that
php developers aren't paying any attention :(
Previous Comments:
------------------------------------------------------------------------
[2002-06-03 09:40:17] mfischer@php.net
Update version.
------------------------------------------------------------------------
[2002-05-17 13:37:42] agustinchernitsky@hotmail.com
Running PHP 4.2.1
Win2K Server with all Security Updates
Still getting the ISAPI module error. My event Log shows:
Event Type: Warning
Event Source: W3SVC
Event Category: None
Event ID: 36
Date: 17/05/2002
Time: 14:09:30
User: N/A
Computer: SERVER2
Description:
The server failed to load application '/LM/W3SVC/24/Root/admin'. The
error was 'The application called an interface that was marshalled for
a different thread.
'.
For additional information specific to this message please visit the
Microsoft Online Support site located at:
http://www.microsoft.com/contentredirect.asp.
Where /Root/admin is the virtual dir running PHP files.
------------------------------------------------------------------------
[2002-05-15 10:23:32] mdavis@cbsh.com
I beleive that is what it was being called when I downloaded it, maybe
I am mistaken.
Anyway I am now running php 4.2.1 and am having the same problem.
Windows 2000 Server
Stock PHP 4.2.1 install
Stock MySQL 3.29 install
Stock phpBB 2.0 install
------------------------------------------------
The HTTP server encountered an unhandled exception while processing the
ISAPI Application '
php4ts!zend_strndup + 0x2B
+ 0xA05E5983
------------------------------------------------
------------------------------------------------------------------------
[2002-05-14 17:46:39] rasmus@php.net
Uh, PHP 2.0 Gold? What the heck is that?
------------------------------------------------------------------------
[2002-05-14 17:08:08] mdavis@cbsh.com
Any update to this? Using PHP 2.0 Gold and still haveing this problm:
php4ts!zend_strndup + 0x2B
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/15333
--
Edit this bug report at http://bugs.php.net/?id=15333&edit=1