Bug #14882 Updated: PHP as ISAPI dll causes ASP to generate Internal Server Error 5000

From: Date: Sun, 07 Jul 2002 05:00:06 +0000
Subject: Bug #14882 Updated: PHP as ISAPI dll causes ASP to generate Internal Server Error 5000
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-13354@lists.php.net to get a copy of this message
ID: 14882 Updated by: php-bugs@lists.php.net Reported By: carlosi@bellatlantic.net -Status: Feedback +Status: No Feedback Bug Type: IIS related Operating System: Windows 2000 PHP Version: 4.1.1 New Comment: No feedback was provided for this bug for over a month, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". Previous Comments: ------------------------------------------------------------------------ [2002-06-03 12:23:54] mfischer@php.net Please try a newever version and also see if the CGI works better for you. ------------------------------------------------------------------------ [2002-01-06 00:09:27] carlosi@bellatlantic.net I just noticed that if you also install the php4isapi.dll as an ISAPI Filter then the problem disappears.... What I mean is I installed the ISAPI version of PHP under: Home directory, settings, etc.... and the ISAPI Filter under the ISAPI Filters Tab. ------------------------------------------------------------------------ [2002-01-05 23:45:49] carlosi@bellatlantic.net The problem only appears when running under Windows 2000 and IIS5. I tried the same configuration with Windows NT with no problems. The problem appears even when no extensions are loaded. After running a PHP script using the ISAPI PHP dll almost all ASPs start generating "Internal Server Error messages (500)". I checked the logs and the Event viewer and couldn't come up with anything useful. I saw this reported by many people in the bug database but no successfull solution has been found. PLEASE NOTE that all php scripts continue to work perfectly! therefore if you are trying to find problems with php you won't! It is only when you have to have phps and asps running on the same server on a Windows 2000 with IIS5. As soon as I change to the CGI version (php.exe) the problem disappears but it is too slow! I need to prove PHP is faster than ASP because I want to get rid of those ASPs.... in the meantime they have to "live together" Thanks! ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=14882&edit=1

« previous php.bugs (#13354) next »