#44974 [NoF->Csd]: ZipArchive can't open large archives
ID: 44974
Updated by: pajoye@php.net
Reported By: florian dot ember at gmail dot com
-Status: No Feedback
+Status: Closed
Bug Type: Zip Related
Operating System: Debian
PHP Version: 5.2.6
Assigned To: pajoye
New Comment:
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at
http://www.php.net/downloads.php
Previous Comments:
------------------------------------------------------------------------
[2008-08-26 01:00:03] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2008-08-18 07:35:43] pajoye@php.net
You can try using our pre-built binaries or windows or on any other
linux distributions using our src packages. PHP does not have to be
installed to test a fresh build.
------------------------------------------------------------------------
[2008-08-08 00:31:49] florian dot ember at gmail dot com
Sorry, I can't do that. I ran the reproduce code on a shared host and I
don't have a Debian / Linux installation at hand.
------------------------------------------------------------------------
[2008-08-07 23:43:08] pajoye@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.3-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.3-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.3-win32-installer-latest.msi
------------------------------------------------------------------------
[2008-07-29 11:07:39] vadim at vadiaz dot com
This looks like exactly the same bug as
http://bugs.php.net/bug.php?id=44055 - zip
archive with more than 1000
entries in root or archive produce an error on 64bit Linux systems
I fixed it and rebuild php from source for my servers
the patch is:
--- php-5.2.6.orig/ext/zip/lib/zip_open.c 2008-01-14 05:19:41.000000000
+0200
+++ php-5.2.6/ext/zip/lib/zip_open.c 2008-07-29 14:04:36.000000000
+0300
@@ -313,7 +313,7 @@
/* go to start of cdir and read it entry by entry */
bufp = NULL;
clearerr(fp);
- fseek(fp, -(cd->size+cd->comment_len+EOCDLEN), SEEK_END);
+ fseek(fp, -((long)(cd->size+cd->comment_len+EOCDLEN)), SEEK_END);
if (ferror(fp) || ((unsigned int)ftell(fp) != cd->offset)) {
/* seek error or offset of cdir wrong */
if (ferror(fp))
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/44974
--
Edit this bug report at http://bugs.php.net/?id=44974&edit=1
Thread (8 messages)