#47826 [Opn->Csd]: undefined symbol: sqlite3_enable_load_extension
ID: 47826
Updated by: scottmac@php.net
Reported By: oeriksson at mandriva dot com
-Status: Open
+Status: Closed
Bug Type: SQLite related
Operating System: Mandriva Linux
PHP Version: 5.3.0RC1
New Comment:
This bug has been fixed in CVS.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
Thank you for the report, and for helping us make PHP better.
Noticed the error after looking at the code again.
Previous Comments:
------------------------------------------------------------------------
[2009-03-29 17:42:20] scottmac@php.net
What configure line did you use?
------------------------------------------------------------------------
[2009-03-29 10:05:34] oeriksson at mandriva dot com
Description:
------------
On Mandriva Linux Cooker I get:
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php/extensions/sqlite3.so' -
/usr/lib/php/extensions/sqlite3.so: undefined symbol:
sqlite3_enable_load_extension in Unknown on line 0
We have sqlite3-3.6.11
I noticed that SQLITE_OMIT_LOAD_EXTENSION is unset in main/php_config.h
and should in this case be set to 1.
$ grep SQLITE_OMIT_LOAD_EXTENSION main/php_config.h
/* #undef SQLITE_OMIT_LOAD_EXTENSION */
Reproduce code:
---------------
Just running php-cli
Expected result:
----------------
It should work
Actual result:
--------------
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php/extensions/sqlite3.so' -
/usr/lib/php/extensions/sqlite3.so: undefined symbol:
sqlite3_enable_load_extension in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=47826&edit=1
Thread (3 messages)