#47942 [Opn->Bgs]: dynamic library suhosin.so could not be loaded
| From: | kalle@php.net | Date: | Fri, 10 Apr 2009 07:59:24 +0000 |
| Subject: | #47942 [Opn->Bgs]: dynamic library suhosin.so could not be loaded | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-135706@lists.php.net to get a copy of this message | ||
ID: 47942
Updated by: kalle@php.net
Reported By: rajesh dot mohan at asia dot bnpparibas dot com
-Status: Open
+Status: Bogus
Bug Type: Dynamic loading
Operating System: AIX 5.3
PHP Version: 5.2CVS-2009-04-10 (snap)
New Comment:
Your php.ini tries to load an extension that does not exist on your
system, check that you have set the extension_dir & extension directives
correctly.
For more help on that paticular extension, contact the extension
authors of suhosin.
Previous Comments:
------------------------------------------------------------------------
[2009-04-10 03:48:45] rajesh dot mohan at asia dot bnpparibas dot com
Description:
------------
After installation of PHP 5.2.6 on AIX 5.3, i tried to test it in the
command line through php -v and php -r "phpinfo()" and both fails with
the reason suhosin.so could not be loaded as below:
$UAT>/opt/pware/bin>php -r "phpinfo()"
PHP Warning: PHP Startup: Unable to load dynamic library
'./suhosin.so' - Could not load module ..
System error: No such file or directory in Unknown on line 0
PHP Parse error: syntax error, unexpected $end in Command line code on
line 1
$UAT>/opt/pware/bin>php -v
PHP Warning: PHP Startup: Unable to load dynamic library
'./suhosin.so' - Could not load module ..
System error: No such file or directory in Unknown on line 0
PHP 5.2.6 with Suhosin-Patch 0.9.6.2 (cli) (built: Dec 26 2008
09:14:36)
Copyright (c) 1997-2008 The PHP Group
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=47942&edit=1