Bug #15801 Updated: unjustified open_basedir restriction on copy()

From: Date: Fri, 01 Mar 2002 03:07:29 +0000
Subject: Bug #15801 Updated: unjustified open_basedir restriction on copy()
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-1369@lists.php.net to get a copy of this message
ID: 15801 Updated by: rasmus@php.net Reported By: vedad@kajtaz.net Status: Open Bug Type: Filesystem function related Operating System: linux rh PHP Version: 4.1.2 New Comment: Well, the reason it works in 4.0.4 is that no open_basedir check is done at all on copy() in that version. It is wide open. Now the check is done, and yes, in your case it is due to the symlink you have. The open_basedir check is currently not very good at dealing with symlinked directories. Previous Comments: ------------------------------------------------------------------------ [2002-02-28 21:32:31] vedad@kajtaz.net Hi again, i've got the same problem with 4.1.0 with mime upload patch... While uploaded-file-copy may be circumvented with move_uploaded_file, i found no solution for copying not-uploaded files from one place to another. Note i'm always using full path in copy() and move_uploaded_file(), and that all paths are within open_basedir folder... I've got no choice but downgrading even more... :( ------------------------------------------------------------------------ [2002-02-28 20:48:41] vedad@kajtaz.net I've done some tests, and this is not specific to uploaded file. The copy() doesn't work at all any more, always giving open_basedir error. I've checked phpinfo() output from faulty scripts, and open_basedir paths are correct. Please let me know if you need more info... -- vedad ------------------------------------------------------------------------ [2002-02-28 20:07:05] vedad@kajtaz.net Hello, I've got a weird open_basedir restriction error on copy() of an uploaded file. This occurs with php4.1.2, after upgrading from the old 4.0.4pl1, which didn't have the problem. php.ini and apache configuration were unchanged. Virtual host settings: php_admin_value open_basedir /path/to/website/ php_admin_value upload_tmp_dir /path/to/website/temp I'm now getting an error when file is being copied from /path/to/website/temp/<phptempfile> to /path/to/website/somewhereelse/ Error label: Warning: open_basedir restriction in effect. File is in wrong directory in /path/to/website/somescript.phtml on line 1055 As copy-source, copy-destination and tmp folder are all within open_basedir, I really don't get the problem. Am I missing something? Please note that in my case, /path/to/website is a symbolic link to /mnt/mountpoint/to/website, but i had no more success by putting the "real" path into open_basedir section. Thanx, -- vedad ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=15801&edit=1

« previous php.bugs (#1369) next »