From: neva@nevalabs.org
Operating system: Redhat 7.2
PHP version: 4.2.1
PHP Bug Type: PCRE related
Bug description: Compiling with --with-pcre-regex=shared breaks php module
Using --with-pcre-regex=shared with ./configure causes apache to give this
message when starting:
/usr/local/apache_1.3.26/bin/apachectl start
Syntax error on line 237 of /usr/local/apache_1.3.26/conf/httpd.conf:
Cannot load /usr/local/apache_1.3.26/libexec/libphp4.so into server:
/usr/local/
apache_1.3.26/libexec/libphp4.so: undefined symbol: php_pcre_replace
/usr/local/apache_1.3.26/bin/apachectl start: httpd could not be started
This simple configure options leads to this problem:
./configure --with-config-file-path=/usr/local/apache_1.3.26/conf
--includedir=/usr/include --with-apxs=/usr/local/apache_1.3.26/bin/apxs
--disable-debug --enable-track-vars=yes --enable-memory-limit
--enable-inline-optimization --with-gnu-ld --with-pcre-regex=shared
Details about the system:
Redhat 7.2, with all updates (glibc-2.2.4)
Apache 1.3.26
PHP 4.2.1
Excluding --with-pcre-regex=shared from the ./configure line solves the
problem, but this option used to work, at least with many older php 4.x
versions.
If you need any other info, please let me know.
Thanks,
Claudio Neves
--
Edit bug report at http://bugs.php.net/?id=18268&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=18268&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=18268&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=18268&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=18268&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=18268&r=support
Expected behavior: http://bugs.php.net/fix.php?id=18268&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=18268&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=18268&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=18268&r=globals