#48822 [Opn->Fbk]: Bus error in Apache after PHP 5.3.0 installed
| From: | jani@php.net | Date: | Tue, 07 Jul 2009 11:35:25 +0000 |
| Subject: | #48822 [Opn->Fbk]: Bus error in Apache after PHP 5.3.0 installed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-139382@lists.php.net to get a copy of this message | ||
ID: 48822
Updated by: jani@php.net
Reported By: stevenf at panic dot com
-Status: Open
+Status: Feedback
Bug Type: Apache2 related
Operating System: Mac OS X Server 10.5.7
PHP Version: 5.3.0
New Comment:
1. Do you load any extensions in the php.ini used? Especially some 3rd
party zend exts?
2. Remove /lib suffix from any configure option values. It's never
needed
3. Backtrace..?
Previous Comments:
------------------------------------------------------------------------
[2009-07-06 17:37:05] stevenf at panic dot com
Description:
------------
After compiling and installing PHP 5.3.0, Apache reports a bus error
when I try to
restart it:
sporty:php-5.3.0 stevenf$ sudo /usr/local/apache2/bin/apachectl
graceful
/usr/local/apache2/bin/apachectl: line 78: 25030 Bus error
$HTTPD -k $ARGV
The problem goes away if I roll back to PHP 5.2.10.
I have submitted the results of make test.
Note that this is a PowerPC machine -- this has caused some PHP
problems in the past.
Uname info:
Darwin sporty.panic.com 9.7.0 Darwin Kernel Version 9.7.0: Tue Mar 31
22:54:29 PDT 2009;
root:xnu-1228.12.14~1/RELEASE_PPC Power Macintosh
Config string:
./configure --with-openssl --with-apxs2=/usr/local/apache2/bin/apxs -
-with-mysql-
sock=/var/mysql --with-mysql=/usr --with-xmlrpc --enable-mbstring --
without-sqlite --
enable-sockets --with-curl --with-gd --with-jpeg-dir=/usr/local/lib --
with-png-
dir=/usr/local/lib
Apache info:
Apache/2.2.10 (Unix) DAV/2 PHP/5.2.10 mod_ssl/2.2.10 OpenSSL/0.9.7l
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=48822&edit=1