ID: 48880
Comment by: patrick at patrickpatoray dot com
Reported By: brwarner at rogers dot com
Status: Open
Bug Type: Safe Mode/open_basedir
PHP Version: 5.3.0
New Comment:
I am having the same problem on Mac OS X 10.5.7.
Intermittent failures. It will work after a refresh or two. Each
time, it seems to have a slightly
different allowed path(s). I've pasted a few example error lines
below:
Warning: Unknown: open_basedir restriction in effect.
File(/www/htdocs/common/functions/class.Base.php) is
not within the allowed path(s): (X-Powered-By: PHP/5.3.0) in Unknown
on line 0
Warning: Unknown: open_basedir restriction in effect.
File(/www/htdocs/common/functions/class.Base.php) is
not within the allowed path(s): (Mozilla/5.0 (Macintosh; U; Intel Mac
OS X 10_5_7; en-us) AppleWebKit/530.18
(KHTML, like Gecko) Version/4.0.1 Safari/530.18) in Unknown on line 0
Warning: Unknown: open_basedir restriction in effect.
File(/www/htdocs/common/functions/class.Base.php) is
not within the allowed path(s): ( Mac OS X 10_5_7; en-us)
AppleWebKit/530.19.2 (KHTML, like Gecko)
Version/4.0.2 Safari/530.19) in Unknown on line 0
Warning: Unknown: open_basedir restriction in effect.
File(/www/htdocs/common/functions/class.Base.php) is
not within the allowed path(s): (�O) in Unknown on line 0
I am using Apache 2.2.11 with PHP configured as a module. Thread
safety is disabled.
I am setting open_basedir for each virtual host using php_admin_value
The file class.Base.php is included via an auto_prepend line in
httpd.conf (not on a virtual host basis, but
for all virtual hosts), which is why it shows "in Unknown on line 0"
for each error message
As mentioned by brwarner, I have never seen this in any other version
of PHP until 5.3.0.
Previous Comments:
------------------------------------------------------------------------
[2009-07-12 15:05:53] pajoye@php.net
not windows specific (given the comments)
------------------------------------------------------------------------
[2009-07-12 15:03:03] brwarner at rogers dot com
Yes, they also appear to have ASCII characters outside those of
letters,
numbers, and symbols. Almost like it is being corrupted.
------------------------------------------------------------------------
[2009-07-12 11:09:29] te at powie dot de
We noticed the same problem under Suse Linux + Apache2 + php 5.3.0.
Warning:
Warning: Unknown: open_basedir restriction in effect.
File(/srv/www/web1/html/cms/mod/gb/index.php) is not within the allowed
path(s): (¶/www/web14/html/) in Unknown on line 0
The displayed allowed paths are random, from other vhosts on the
system!
------------------------------------------------------------------------
[2009-07-10 18:27:02] brwarner at rogers dot com
In the httpd file the following line includes the virtual hosts file
# Virtual hosts
Include conf/extra/httpd-vhosts.conf
In that file here is what the virtual host for that specific domain is
<VirtualHost *:80>
ServerName brwarner.co.cc
ServerAlias www.brwarner.co.cc 127.0.0.1
DocumentRoot "C:/www/brwarner.co.cc"
php_admin_value open_basedir
"C:\www\brwarner.co.cc;C:\svn;C:\Program
Files\PHP\PEAR;C:\WINDOWS\Temp;C:\djgpp"
php_admin_value short_open_tag "Off"
ErrorLog "C:/www/logs/brwarner_error.log"
ErrorDocument 404 /error404.php
</VirtualHost>
I have several other virtual hosts with look practically idential.
I have never seen this in any other version of PHP besides 5.3.0 and
not before I upgraded, and I have had these sites working for a while
so if it was there I probably would have seen it.
------------------------------------------------------------------------
[2009-07-10 18:22:00] jani@php.net
Is open_basedir set in httpd.conf or in some .htaccess file?
And does this happen _only_ with PHP 5.3.0 ?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/48880--
Edit this bug report at http://bugs.php.net/?id=48880&edit=1