#49039 [Com]: Can't pass file name with subfolder name 3 characters or less
| From: | sant9442 at gmail dot com | Date: | Thu, 23 Jul 2009 19:09:07 +0000 |
| Subject: | #49039 [Com]: Can't pass file name with subfolder name 3 characters or less | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-140150@lists.php.net to get a copy of this message | ||
ID: 49039
Comment by: sant9442 at gmail dot com
Reported By: sant9442 at gmail dot com
Status: Open
Bug Type: CGI related
Operating System: Windows
PHP Version: 5.3.0
New Comment:
It should be noted that we spend 10 hours on this issue, first
believing it was related to changed to the php.ini options
;doc_root =
;cgi.fix_pathinfo = 1
cgi.force_redirect = 0
and CGI environment strings:
DOCUMENT_ROOT=d:\wc63\http
PATH_INFO=/pwe/helloworld.php
SCRIPT_NAME=/pwe/helloword.php
PATH_TRANSLATED=d:\wc63\http\pwe\helloworld.php
SCRIPT_FILENAME=d:\wc63\http\pwe\helloworld.php
which all research (googling) of "no input file specified" related to.
Reqardless of what we tried, it would not work until I discovered the 3
character folder name off the root folder was the problem. Renaming it
to 4 characters or more, solved the issue and that was discovered when
all other URLS were working and we noticed the only difference was the 3
character length of the folder name.
This comment is mentioned so that time isn't wasted on the above issues
related and possible reasons for "no input file specified."
Previous Comments:
------------------------------------------------------------------------
[2009-07-23 19:00:21] sant9442 at gmail dot com
Description:
------------
After upgrading to 5.3 from 5.2.6, we began to see "No input file
specified" errors with working URLs: /pwe/helloworld.php
It was eventually discovered that renaming the pwe folder to something
with 4 characters or more, then it would work. A subfolder name with 3
characters or less failed:
Reproduce code:
---------------
A url would be:
/pwe/helloworld.php
where pwe is a subfolder off the web server root document folder:
d:\wc63\http
So the web server script mapping spawn basically did this which can be
emulated manually:
cd \wc63\http
d:\wc63\php-cgi.exe d:\wc63\http\pwe\helloworld.php
This failed. Rename it to pwe1 and try:
d:\wc63\php-cgi.exe d:\wc63\http\pwe1\helloworld.php
and it should it work.
Expected result:
----------------
A page is displayed
Actual result:
--------------
"No Input File Specified"
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=49039&edit=1