#48843 [Bgs]: Can't seem to stop Deprecated messages in php.log
ID: 48843
Updated by: derick@php.net
Reported By: jeff at jeffweinberger dot com
Status: Bogus
Bug Type: PHP options/info functions
Operating System: Mac OS/X 10.5.7 client version
PHP Version: 5.3.0
New Comment:
I am pretty sure this is fixed, try the snapshot (you don't have to
*install* it over your existing install) if you want to verify. Also,
you didn't actually show the messages....
Previous Comments:
------------------------------------------------------------------------
[2009-07-23 23:27:23] jeff at jeffweinberger dot com
Thanks...but the time zone is set.
That was a separate issue, but was resolved by setting the timezone in
php.ini.
This issue remains despite timezone being set and I have no evidence
that it is related.
If there is a test I can run to see if it is related, please suggest
it.
Sorry...and thanks!
PLEASE RE-OPEN)
------------------------------------------------------------------------
[2009-07-23 22:34:32] jani@php.net
This is most likely just duplicate of other reports about this same
issue (having to do with timezone not being set) and as that is fixed
already -> closing as bogus.
------------------------------------------------------------------------
[2009-07-23 22:16:20] jeff at jeffweinberger dot com
Thank you.
As a policy, because this is a production environment, I cannot use a
CVS snapshot until it is a stable release.
I will try 5.3.1 when it becomes stable.
In the meantime, are there any other workarounds?
Thank you!)
------------------------------------------------------------------------
[2009-07-08 00:58:31] jeff at jeffweinberger dot com
Description:
------------
I am getting large numbers of "PHP Deprecated..." messages in my
php.log file (I expect this, based on some not-yet-updated code).
Until I update all my PHP code, I want to shut off these messages
(they are causing the log file to exceed several GB).
I have tried all of the following in php.ini:
error_reporting = E_ALL & ~E_DEPRECATED & E_ERROR & E_WARNING &
E_PARSE & E_NOTICE & E_CORE_ERROR & E_USER_ERROR & E_USER_WARNING &
E_USER_NOTICE & E_COMPILE_ERROR & E_COMPILE_WARNING
error_reporting = ~E_DEPRECATED & E_ALL & E_ERROR & E_WARNING &
E_PARSE & E_NOTICE & E_CORE_ERROR & E_USER_ERROR & E_USER_WARNING &
E_USER_NOTICE & E_COMPILE_ERROR & E_COMPILE_WARNING
error_reporting = E_ALL & E_ERROR & E_WARNING & E_PARSE & E_NOTICE &
E_CORE_ERROR & E_USER_ERROR & E_USER_WARNING & E_USER_NOTICE &
E_COMPILE_ERROR & E_COMPILE_WARNING & ~E_DEPRECATED
error_reporting = E_ERROR & E_CORE_ERROR & E_USER_ERROR &
E_COMPILE_ERROR & E_COMPILE_WARNING & ~E_DEPRECATED
error_reporting = ~E_DEPRECATED & E_ERROR & E_CORE_ERROR &
E_USER_ERROR & E_COMPILE_ERROR & E_COMPILE_WARNING
error_reporting = E_ALL & ~E_DEPRECATED
error_reporting = 24575
error_reporting = 3
and after each change, I restart Apache (PHP is running as a CGI with
Apache 2.2.11) and PHP.
in my php_info() display, the error_reporting value shows the correct
value for the then-active line (above), but the log entries still
appear.
I have tried the suggestions of several on the PHP-General mailing
list to no avail.
Please let me know if there is additional information that will help.
Expected result:
----------------
"PHP Deprecated..." messages no longer appear in php.log
Actual result:
--------------
"PHP Deprecated..." messages still appear in large numbers php.log
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=48843&edit=1
Thread (9 messages)