#49064 [Opn->Asn]: --enable-session=shared doesn't work

From: Date: Sun, 26 Jul 2009 19:30:43 +0000
Subject: #49064 [Opn->Asn]: --enable-session=shared doesn't work
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-140282@lists.php.net to get a copy of this message
ID: 49064 Updated by: jani@php.net Reported By: php-bugs at vandekamer dot com -Status: Open +Status: Assigned Bug Type: Session related Operating System: Linux PHP Version: 5.3.0 -Assigned To: +Assigned To: jani Previous Comments: ------------------------------------------------------------------------ [2009-07-26 15:01:07] php-bugs at vandekamer dot com Description: ------------ A build with --enabled-session=shared compiles as expected a session.so. The module loads correctly, but when we start a session it raises the following error: /usr/bin/php-cgi: symbol lookup error: /usr/lib/php/20090626/session.so: undefined symbol: php_url_scanner_reset_vars When we repeat the build with exactly the same parameters except the =shared part, everything works fine. Of course with a buildin session. Reproduce code: --------------- Build a php-cgi with the following ./configure: --with-layout=GNU --with-config-file-path=/etc/php --with-config-file-scan-dir=/etc/php/conf.d --prefix=/usr --mandir=/usr/share/man --disable-all --enable-session --enable-cgi --disable-cli ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=49064&edit=1

« previous php.bugs (#140282) next »