#48882 [Com]: "PHP Startup: Timezone database is corrupt"
| From: | bug dot odesk at gmail dot com | Date: | Thu, 06 Aug 2009 16:50:47 +0000 |
| Subject: | #48882 [Com]: "PHP Startup: Timezone database is corrupt" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-140731@lists.php.net to get a copy of this message | ||
ID: 48882
Comment by: bug dot odesk at gmail dot com
Reported By: vonpreussen at 2secure dot us
Status: No Feedback
Bug Type: Date/time related
Operating System: centos 5
PHP Version: 5.3.0
New Comment:
CentOS 5, php 5.3 cli. tzdata 2009i.
$ php -v
PHP Strict Standards: PHP Startup: It is not safe to rely on the
system's timezone settings. Please use the date.timezone setting, the TZ
environment variable or the date_default_timezone_set() function. In
case you used any of those methods and you are still getting this
warning, you most likely misspelled the timezone identifier. We selected
'America/Chicago' for 'CDT/-5.0/DST' instead in Unknown on line 0
PHP Fatal error: PHP Startup: Timezone database is corrupt - this
should *never* happen! in Unknown on line 0
Segmentation fault
strace log.
http://pastebin.com/f2b4d38c7
Previous Comments:
------------------------------------------------------------------------
[2009-07-18 01:00:01] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2009-07-10 21:55:33] vonpreussen at 2secure dot us
no. yum install.
------------------------------------------------------------------------
[2009-07-10 21:31:08] derick@php.net
Did you compile PHP yourself?
------------------------------------------------------------------------
[2009-07-10 19:49:48] vonpreussen at 2secure dot us
Description:
------------
updated php and it now fails every time over timezone issue.
had latest tz data (tzdata-2009j) and back-stepped to 2009f and no
change.
httpd error log (no php error logging is done even though it is turned
on in /etc/php.ini) -- date.timezone = "UTC" and is ignored and the
/etc/sysconf/clock file OR date_default_timezone_set() function (most
likely, since removing the file gives the old system date) is used by
php instead:
"PHP Warning: PHP Startup: It is not safe to rely on the system's
timezone settings. You are *required* to use the date.timezone setting
or the date_default_timezone_set() function. In case you used any of
those methods and you are still getting this warning, you most likely
misspelled the timezone identifier. We selected 'America/Los_Angeles'
for 'PDT/-7.0/DST' instead in Unknown on line 0
"PHP Fatal error: PHP Startup: Timezone database is corrupt - this
should *never* happen! in Unknown on line 0"
/etc/localtime is a copy of the file for MDT and it shows up for OS
time and nothing else.
googling reveals that this same error keeps popping up in new php
versions as if the original tz scripts get re-used each time without any
updating until the same problem emerges after release. then the patch is
made and the original scripts remain unchanged.
Reproduce code:
---------------
core startup crash
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=48882&edit=1