#49173 [Fbk]: Php don't work with mod_fcgid if I load a extension
| From: | srinatar@php.net | Date: | Thu, 06 Aug 2009 21:36:53 +0000 |
| Subject: | #49173 [Fbk]: Php don't work with mod_fcgid if I load a extension | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-140745@lists.php.net to get a copy of this message | ||
ID: 49173
Updated by: srinatar@php.net
Reported By: malina dot laszlo at malina dot hu
Status: Feedback
Bug Type: Dynamic loading
Operating System: Debian Lenny
PHP Version: 5.3.0
New Comment:
i very much doubt if this is a php bug.
i bet that extension like gd.so is probably depending on a library
which it is probably unable to load in your fastcgi environment.
you can verify this by running ldd on gd.so and if there is any
dependent library that is not in /lib or /usr/lib (or for that any
matter any directory that is not in /etc/ld.so.conf.d/*.conf) then this
could be the cause.
to confirm this is the issue, you could try loading an extension which
does not depend on libraries that is not in /lib or /usr/lib. if it
works fine, then you could either
a) update your apachectl script to add LD_LIBRARY_PATH to include all
your dependent library locations
b) create a custom .conf file under /etc/ld.so.conf.d which contains
the list of directories to search in your environment.
Previous Comments:
------------------------------------------------------------------------
[2009-08-06 09:43:57] malina dot laszlo at malina dot hu
Hi!
I tried to compile the PHP (not snapshot, but release). There are two
ways to do:
1. I am updating system libraries (libgd, libpng, etc) and compiling gd
extension by shared
(--with-gd=shared,/usr and png,jpg,xpm, freetype,etc by shared)
2. I compiling gd extension by "embedded" (it is not shared).
(--with-gd [it is embedded for me] and png, jpg,xpm, etc is not
shared)
Results:
Point 1: it is failed, same error
Point 2: this is good, no error!
I will try to compile snapshot-php5.3 by shared and "embedded". I'm
curious :)
------------------------------------------------------------------------
[2009-08-06 08:57:47] jani@php.net
Please try using this snapshot:
http://snaps.php.net/php5.3-latest.tar.gz
For Windows:
http://windows.php.net/snapshots/
------------------------------------------------------------------------
[2009-08-06 08:07:09] malina dot laszlo at malina dot hu
Hi!
I am trying to load extensions and each works well except for the
gd.so. If I load gd, server send me "Status 500" and written above logs.
Before there was already a compiling problem (gdhelper), but this is
no, without error compiled.
Thanks for your help!
Bearcheese
------------------------------------------------------------------------
[2009-08-06 00:31:26] malina dot laszlo at malina dot hu
Description:
------------
Hello!
I compiled php-5.3.0 (CGI), apache-2.2.12 (mpm-worker) and
mod_fcgid-2.2.0 on Debian Lenny.
I have more extension: mysql, mysqli, pdo, gd, gettext, memcache,
imagick, idn, etc.
When I give extension_dir (with absoluth path) and I does NOT allow to
load extensions then no problem (and no extension).
When I does allow to load only ONE extension (for example gd.so), then
the server send me "Internal server error" (status 500).
I can see in apache error-log:
[warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi
server error.
[info] (104)Connection reset by peer: mod_fcgid: can't read data from
fcgid handler
[warn] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed
in handle_request function
What is problem?
(Sorry for my bad English!)
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=49173&edit=1