#35119 [Com]: PHP failed to open files in folders with non-english utf8 chars
ID: 35119
Comment by: john dot peterson3 at hotmail dot com
Reported By: maltzee at hotmail dot com
Status: Open
Bug Type: Feature/Change Request
Operating System: Windows
PHP Version: 5.0.5
New Comment:
Has anyone found a cause and solution for this? My Apache 2.0.54 and
PHP 5.2.9 does the same thing. It can't open php files that reside in
any path with two-byte western european letters such as å (%c3%a5), ä
(%c3%a4) or ö (%c3%b6).
Previous Comments:
------------------------------------------------------------------------
[2005-11-06 01:25:59] maltzee at hotmail dot com
Description:
------------
OS: Windows XP Traditional Chinese
I installed an Apache2 server to a folder with double-byte character.
(e.g C:\ä¸å\Apache2\)
To support Apache2, I have to convert the httpd.conf into UTF8 format.
PHP5.0.5 is installed as Apache2 module by httpd.conf.
LoadModule php5_module
"C:/ä¸å/Apache2/php-5.0.5-Win32/php5apache2.dll"
AddType application/x-httpd-php .php
When I try to access my test page, the following returned:
Warning: Unknown: failed to open stream: No such file or directory in
Unknown on line 0
Warning: Unknown: Failed opening 'C:\ä¸å\Apache2\htdocs\index.php'
for inclusion (include_path='.;C:\php5\pear') in Unknown on line 0
I guess Apache saves the utf8 path string from httpd.conf and passes
them to PHP module. PHP assumes the input path as native mbstring. This
might be the cause.
Best Regards,
Maltzee
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=35119&edit=1
Thread (3 messages)