#49310 [Opn]: Default install fails to load dll libraries
| From: | kalle@php.net | Date: | Thu, 20 Aug 2009 13:29:06 +0000 |
| Subject: | #49310 [Opn]: Default install fails to load dll libraries | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-141310@lists.php.net to get a copy of this message | ||
ID: 49310
Updated by: kalle@php.net
Reported By: markvanrossum at yahoo dot co dot uk
Status: Open
Bug Type: Windows Installer
Operating System: Windows XP
PHP Version: 5.2.10
New Comment:
Is this for any specific extensions? Does it help to add "C:\php\" to
your PATH env variable?
Previous Comments:
------------------------------------------------------------------------
[2009-08-20 11:36:03] markvanrossum at yahoo dot co dot uk
Description:
------------
Using a default install of the MSI, choosing "no webserver" and then
running php from the command line returns a popup box of:
"This application has failed to start because xxx.dll was not found.
Re-installing the application may fix the problem"
and text into the console of
"PHP Warning: PHP Startup: Unable to load dynamic library
'C:\php\ext\xxxx.dll' - The specified module could not be found.
in Unknown on line 0"
for some extensions that are enabled. Some other extensions load OK.
After doing lots of research, it seems that some extensions require
additional dll files from vendors. The installer should warn of this
when you choose the extension. The error message above is wrong where
it says "because xxx.dll was not found" and "The specified module could
not be found" and there are many posts on internet forums from people
trying to fix this issue by checking their extension_dir etc.
Expected result:
----------------
PHP to run cleanly with no errors after a default install with no
configuration changes. If more dlls are required from vendors then this
to be stated, rather than the incorrect message "The specified module
could not be found"
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=49310&edit=1