Bug #15333 Updated: strndup access violation

From: Date: Mon, 15 Jul 2002 13:50:56 +0000
Subject: Bug #15333 Updated: strndup access violation
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-14211@lists.php.net to get a copy of this message
ID: 15333 Updated by: agustinchernitsky@hotmail.com Reported By: david@harksystems.com Status: Critical Bug Type: IIS related Operating System: Windows 2000 Pro PHP Version: 4.2.1 New Comment: Okey, this is an update... Interesting one. Since I really need PHP running in ISAPI (for cookies, performance, etc), I reinstalled this weekend our main development server. I installed the server with Windows 2000 Server and applied Service Pack 2. Before we updated the server with the latests security patches from MS, my server was running SP2 and PHP 4.1.2 with no problems. After the Security Patches, everything went wrong. Now, what happened with a Win2k clean installation, with SP2 and PHP 4.2.1: It didn´t work. Got the same PHP Isapi error as before. Hope it helps. Previous Comments: ------------------------------------------------------------------------ [2002-07-08 11:45:17] jtate@php.net I looked for the solution to this bug for more time than I had to spend. Problem A is that debugging under IIS is more than a little bit of a hassle. Problem B is that it seems to be a bogus pointer or corrupted memory that causes the access violation, and I wasn't able to track it down. Patches that fix the problem are very welcome, in the mean time, changing the security model to "low" seems to be a valid workaround. ------------------------------------------------------------------------ [2002-07-06 07:46:04] mfischer@php.net Reproduced here. Paying attention is relative. The number of developers under win32 is far less then the number of unix developers, simply. ------------------------------------------------------------------------ [2002-07-06 07:24:25] nagender@sancharnet.in I am using latest Download from php.net i.e php 4.2.1 with IIS 5 on Win2k Server running as ISAPI and always get the ACCESS VIOLATION ERROR after 10-15 pages and then every single page. Even when i restart IIS , the problem doesn't go away. On rebooting, the events cycle again. Gone thru all the messages, seems like nobody has much clue as to why newer versions of php are giving this error and strange fact is that php developers aren't paying any attention :( ------------------------------------------------------------------------ [2002-06-03 09:40:17] mfischer@php.net Update version. ------------------------------------------------------------------------ [2002-05-17 13:37:42] agustinchernitsky@hotmail.com Running PHP 4.2.1 Win2K Server with all Security Updates Still getting the ISAPI module error. My event Log shows: Event Type: Warning Event Source: W3SVC Event Category: None Event ID: 36 Date: 17/05/2002 Time: 14:09:30 User: N/A Computer: SERVER2 Description: The server failed to load application '/LM/W3SVC/24/Root/admin'. The error was 'The application called an interface that was marshalled for a different thread. '. For additional information specific to this message please visit the Microsoft Online Support site located at: http://www.microsoft.com/contentredirect.asp. Where /Root/admin is the virtual dir running PHP files. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/15333 -- Edit this bug report at http://bugs.php.net/?id=15333&edit=1

« previous php.bugs (#14211) next »