ID: 49503
Updated by: jani@php.net
Reported By: mike at fuelsaver-mpg dot com
-Status: Open
+Status: Feedback
Bug Type: Session related
Operating System: Linux 2.6.9-023stab048.6-enterpr
PHP Version: 5.2.10
New Comment:
Please try using this snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows:
http://windows.php.net/snapshots/
Previous Comments:
------------------------------------------------------------------------
[2009-09-08 20:42:09] mike at fuelsaver-mpg dot com
Description:
------------
When I upgraded to php 5.2.10, I had my error log growing to 100s of
MBs with error messages that it was unable to open its semaphore file.
I un-commented the php.ini line: "session.save_path = ", created a
directory that could be written to, and this resolved that particular
error.
However, I'm still getting the following errors, albeit on a less
frequent basis. I got 53 of these in one day however:
[07-Sep-2009 00:24:46] PHP Warning: PHP Startup: mm_create(0,
/home/fuelsa5/tmp/php/session_mm_cgi32010) failed, err mm:core: failed
to open semaphore file (File exists) in Unknown on line 0
There are files being created in the directory, so it's not a
permissions issue. Per the warning, a duplicate file is attempting to
be created.
Expected result:
----------------
I expect not to get so many error messages. I'm not even sure what's
breaking.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=49503&edit=1