#47627 [Ctl->Bgs]: "No input file specified" causing crash
ID: 47627
Updated by: pajoye@php.net
Reported By: danielc at analysisandsolutions dot com
-Status: Critical
+Status: Bogus
Bug Type: CGI related
Operating System: win32 only - WinXP Pro SP3
PHP Version: 5.3CVS-2009-03-11 (snap)
Assigned To: garretts
New Comment:
That's correct and has been analyzed in #49767, will be fixed there.
Please note that the condition is not only that the file does not exist
but also to use when the per directory registry setting is used.
Set this one as bogus as the one will be used to track this bug.
Thanks for having reproduced it Stas :)
Previous Comments:
------------------------------------------------------------------------
[2009-10-13 19:45:11] stas@php.net
I can reproduce it. IIS gives empty path_translated (NULL) when file
not found which crashes here:
UpdateIniFromRegistry(primary_file->filename TSRMLS_CC);
in php_execute_script since primary_file->filename is NULL.
------------------------------------------------------------------------
[2009-08-18 15:53:23] garretts@php.net
I'm unable to reproduce this with Apache 2.2.13, mod_fcgid and
php5.3.1-dev.
I'd recommend a couple of things:
- Since Apache 1.3 isn't really supported at all these days, moving up
to 2.2 would be a good idea.
- Regardless, Apache should be configured to not pass thru requests to
fcgi handlers for files that don't exist.
------------------------------------------------------------------------
[2009-03-11 19:37:28] danielc at analysisandsolutions dot com
Description:
------------
In PHP 5.3, pointing my browser to a .php file that does not exist
causes php-cgi to crash and Apache to return a 500 error. In PHP 5.2.6,
doing so returns output saying "No input file specified."
During the crash, Windows displays the "Please tell Microsoft about
this problem" dialog box. The title is "CGI / FastCGI". The "To see
what data this error report contains" sub dialog box says:
Error signature
szAppName : php-cgi.exe
szAppVer : 5.3.0.0
szModName : php5ts.dll
szModVer : 5.3.0.0
offset : 000cea5d
The "To view technical information about the error report" sub sub
dialog box contains:
C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\WERc9f6.dir00\php-cgi.exe.mdmp
C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\WERc9f6.dir00\appcompat.txt
My Apache 1.3 error log message shows:
[Wed Mar 11 14:59:02 2009] [error] [client 127.0.0.1] Premature end of
script headers: c:/program files/php/php-cgi.exe
My PHP version is:
PHP 5.3.0beta2-dev (cgi-fcgi) (built: Mar 11 2009 17:04:23)
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=47627&edit=1
Thread (7 messages)