Bug #15820 Updated: Apache 1.3.23, MySQL Client 3.23.49, PHP 4.1.2, same error with PHP 4.1.1 befor
| From: | sander@php.net | Date: | Fri, 01 Mar 2002 20:53:34 +0000 |
| Subject: | Bug #15820 Updated: Apache 1.3.23, MySQL Client 3.23.49, PHP 4.1.2, same error with PHP 4.1.1 befor | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-1436@lists.php.net to get a copy of this message | ||
ID: 15820
Updated by: sander@php.net
Reported By: max@linuxwork.de
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: FreeBSD 4.5-STABLE
PHP Version: 4.1.2
New Comment:
Are you sure this is caused by PHP? Does Apache function normally
without PHP?
Previous Comments:
------------------------------------------------------------------------
[2002-03-01 14:21:29] max@linuxwork.de
Hello,
I have a FreeBSD 4.5-STABLE box running, when i start apache first all
works fine, but after like 3 minutes in the logfile i see this
messages:
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
after another 2 minutes the logfile gets flooded of hundred of this
messages:
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
...
...
right after this i get all time this error(this error didn't appear
before):
httpd in malloc(): warning: recursive call
httpd in malloc(): warning: recursive call
[Fri Mar 1 19:49:16 2002] [alert] [client 195.93.64.xx]
/usr/local/httpd/htdocs/qm-dev/.htaccess: RewriteRule: cannot compile
regular expression 'F([0-9]+)(.htm(l)?)?'
httpd in malloc(): warning: recursive call
httpd in malloc(): warning: recursive call
[Fri Mar 1 19:49:19 2002] [alert] [client 217.228.1.xx]
/usr/local/httpd/htdocs/qm-dev/.htaccess: RewriteRule: cannot compile
regular expression 'F([0-9]+)(.htm(l)?)?'
...
...
The php doesn't work well after this, i get sometimes errors, it
tells
me there would be errors in the code, but if i refresh it works fine,
and the apache prints "Internal Server Error"... but this happens only
under high server load. Is it a PHP bug ? What might we do to fix
that?
Ciao,
Max Krüper
P.S. Before we used a Linux Server with PHP 4.0.(4or6) and all worked
fine.
------------------------------------------------------------------------
[2002-03-01 14:17:59] max@linuxwork.de
Hello,
I have a FreeBSD 4.5-STABLE box running, when i start apache first all
works fine, but after like 3 minutes in the logfile i see this
messages:
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
httpd in free(): warning: chunk is already free
after another 2 minutes the logfile gets flooded of hundred of this
messages:
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
httpd in free(): warning: recursive call
...
...
right after this i get all time this error(this error didn't appear
before):
httpd in malloc(): warning: recursive call
httpd in malloc(): warning: recursive call
[Fri Mar 1 19:49:16 2002] [alert] [client 195.93.64.xx]
/usr/local/httpd/htdocs/qm-dev/.htaccess: RewriteRule: cannot compile
regular expression 'F([0-9]+)(.htm(l)?)?'
httpd in malloc(): warning: recursive call
httpd in malloc(): warning: recursive call
[Fri Mar 1 19:49:19 2002] [alert] [client 217.228.1.xx]
/usr/local/httpd/htdocs/qm-dev/.htaccess: RewriteRule: cannot compile
regular expression 'F([0-9]+)(.htm(l)?)?'
...
...
The php doesn't work well after this, i get sometimes errors, it tells
me there would be errors in the code, but if i refresh it works fine,
and the apache prints "Internal Server Error"... but this happens only
under high server load. Is it a PHP bug ? What might we do to fix
that?
Ciao,
Max Krüper
P.S. Before we used a Linux Server with PHP 4.0.(4or6) and all worked
fine.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=15820&edit=1