#50149 [Bgs]: Enabling dynamic extensions make Apache 2.2.14 crash at startup
ID: 50149
User updated by: msabatier dot perso at gmail dot com
Reported By: msabatier dot perso at gmail dot com
Status: Bogus
Bug Type: Dynamic loading
Operating System: Windows 7
PHP Version: 5.2.11
New Comment:
I tried what you asked. Uninstalled PHP 5.2.9, suppressed the PHP dir
and reinstalled 5.2.11.
I got the same issue again.
Issuing
cd c:\php
php -d extension_dir=ext -d extension=php_gd2.dll -m
Gives me a crash of php (the process stops working) without any
message.
Interestingly, if I don't remove the PHP dir after uninstalling PHP
5.2.9, then after installing PHP 5.2.11 everything is working.
Previous Comments:
------------------------------------------------------------------------
[2009-11-11 13:39:43] pajoye@php.net
tr in CLI, that may give you more details:
> cd c:\php
> php -d extension_dir=ext -d extension=php_gd2.dll -m
------------------------------------------------------------------------
[2009-11-11 12:43:22] msabatier dot perso at gmail dot com
The problem occurs even if I don't activate the php_mysql extension, so
no link to any missing libmysql DLL. Just enabling the php_gd2.dll
triggers the problem.
Plus I don't have the issue with 5.2.9 following exactly the same
install problem. So this is not a configuration problem.
------------------------------------------------------------------------
[2009-11-11 11:43:42] pajoye@php.net
You are certainly either missing a DLL or using the wrong DLL (libmysql
certainly).
Be sure to have the PHP directory (where the DLL are) first in your
PATH.
No issue here but configuration problem.
------------------------------------------------------------------------
[2009-11-11 11:04:22] msabatier dot perso at gmail dot com
Description:
------------
I installed PHP 5.2.11 via the installer on a Windows 7 with Apache
2.2.14. I chose to install 3 extensions MySQL, GD2 and XSL.
After editing http.conf to enable PHP, everything runs OK. Only prolem
found is that PHP errors are not appended to the Apache error log.
Then I go to the php.ini and enable any of the 3 extensions I
installed. Then try to restart Apache. Apache process start fails
without giving any error log.
I then uninstall PHP 5.2.11, install 5.2.9 and repeat the same process.
Everything runs fine this time.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50149&edit=1
Thread (10 messages)