ID: 50172
User updated by: erik at navhost dot com
Reported By: erik at navhost dot com
Status: Open
Bug Type: MySQL related
Operating System: Windows Server 2008 R2
PHP Version: 5.3.1RC4
New Comment:
Looking into it further, the comment from pajoye fixes the issue in the
vista-based Server 2008. However, Server 2008 R2 is based on Windows 7
and introduces a new feature on the resolving localhost... see from the
hosts file:
"localhost name resolution is handled within DNS itself."
So I guess this is a windows bug rather than PHP? I can't see an easy
solution here either way.
Previous Comments:
------------------------------------------------------------------------
[2009-11-14 04:06:39] erik at navhost dot com
I can't seem to find the report you're referring to, but the issue
still stands. Is it a IPv6 related issue?
The ::1-line in the hosts file is already commented out.
------------------------------------------------------------------------
[2009-11-13 22:18:38] erik at navhost dot com
Do you mean bug #48805? Anyway, that lin line is already commented out
by an '#' in the server's hosts file. It was that way by default.
------------------------------------------------------------------------
[2009-11-13 21:57:50] pajoye@php.net
see the other bug report about IPv6 being enabled. Comment out the ::1
line in your hosts file and try again (see the other reports or google
about it if you don't know what is it).
------------------------------------------------------------------------
[2009-11-13 21:38:38] erik at navhost dot com
Description:
------------
I've tried to find the solution for this issue here since last month,
but if I install any of the recent 5.3 RCs, PHP simply will not talk to
the MySQL service.
I upgraded from 5.2.10, and the problem was not present in that
version. As far as I recall 5.3.0 and it's RCs did connect but had other
issues later resolved.
When I reinstall 5.2.11, everything is back to normal.
I've reproduced this on 3 servers, all running Windows Server 2008.
Bottom line; 5.2.11 can connect and talk to the MySQL service, 5.3.1RC4
can not.
Reproduce code:
---------------
mysql_connect('localhost', 'root', '***');
Expected result:
----------------
Success!
Actual result:
--------------
(After 60 seconds)
A connection attempt failed because the connected party did not
properly respond after a period of time, or established connection
failed because connected host has failed to respond.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50172&edit=1