#50168 [Asn->Opn]: FastCGI fails with wrong error on HEAD request to non-existant file
| From: | dmitry@php.net | Date: | Mon, 30 Nov 2009 14:43:30 +0000 |
| Subject: | #50168 [Asn->Opn]: FastCGI fails with wrong error on HEAD request to non-existant file | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-145222@lists.php.net to get a copy of this message | ||
ID: 50168
Updated by: dmitry@php.net
Reported By: matthijs at spilgames dot com
-Status: Assigned
+Status: Open
Bug Type: CGI related
Operating System: Linux
PHP Version: 5.2.11
Assigned To: dmitry
New Comment:
This bug has been fixed in SVN.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
Thank you for the report, and for helping us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2009-11-30 14:43:23] svn@php.net
Automatic comment from SVN on behalf of dmitry
Revision: http://svn.php.net/viewvc/?view=revision&revision=291497
Log: Fixed bug #50168 (FastCGI fails with wrong error on HEAD request
to non-existant file)
------------------------------------------------------------------------
[2009-11-30 13:51:23] jani@php.net
Dmitry promised to fix this today. :)
------------------------------------------------------------------------
[2009-11-16 16:26:09] jani@php.net
Fixed summary and category since this isn't a crash.
------------------------------------------------------------------------
[2009-11-16 11:40:36] matthijs at spilgames dot com
I should have mentioned that most webservers do a lookup on the
filesystem and return a 404 by themselves. My webserver does not in this
configuration and for lighttpd you'd have to use the 'check-local'
parameter for your fastcgi configuration to get the same behaviour.
Your question to WHAT actually is in the script: there is no script!
That's the whole point. If I'd do a GET request PHP would be returning
the well known 'No input file specified.' message together with a 404
header. For a HEAD request I'd expect the 404 header without the
message. Instead of returning the header the FastCGI process bails out
with a -1 exit code. It's not a segmentation fault, but it's still a
'crash' of one of the child processes in the sense that it exits
wrongly.
------------------------------------------------------------------------
[2009-11-14 01:24:38] jani@php.net
Works fine for me. Same PHP version, FastCGI, only difference is that I
use lighttpd. Where do you get the idea anything is actually crashing?
Also, WHAT is in that script of yours?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/50168
--
Edit this bug report at http://bugs.php.net/?id=50168&edit=1