Bug #14401 Updated: Wrong include_path from Apache <Directory> config

From: Date: Thu, 18 Jul 2002 14:38:36 +0000
Subject: Bug #14401 Updated: Wrong include_path from Apache <Directory> config
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-14535@lists.php.net to get a copy of this message
ID: 14401 Updated by: vogel@folz.de Reported By: vogel@folz.de -Status: Feedback +Status: Open Bug Type: Apache related Operating System: Linux i386 PHP Version: 4.3.0-dev New Comment: When I said "show stopper" I meant "installation failed", hence I don't know if this fixes the include_path problem. The IMAP part of configure works half way: It detects that SSL libraries are needed for c-client, but the build test fails. The end of config.log reads: configure:34926: checking whether SSL libraries are needed for c-client configure:35086: checking whether IMAP works configure:35119: gcc -o conftest -O2 -march=i386 -mcpu=i686 -fPIC -Wl,-rpath,/usr/X11R6/lib -L/usr/X11R6/lib conftest.c -lcrypt -lpam -lgmp -lgd -lttf -lX11 -lXpm -lpng -lz -ljpeg -ldb -lgdbm -lbz2 -lz -lcrypt -lssl -lcrypto -lresolv -lm -ldl -lnsl -lcrypt 1>&5 /tmp/cc8QGtUw.o: In function `main': /tmp/cc8QGtUw.o(.text+0x112): undefined reference to `mail_open' collect2: ld returned 1 exit status configure: failed program was: #line 35094 "configure" #include "confdefs.h" void mm_log(void){} void mm_dlog(void){} void mm_flags(void){} void mm_fatal(void){} void mm_critical(void){} void mm_nocritical(void){} void mm_notify(void){} void mm_login(void){} void mm_diskerror(void){} void mm_status(void){} void mm_lsub(void){} void mm_list(void){} void mm_exists(void){} void mm_searched(void){} void mm_expunged(void){} char mail_open(); int main() { mail_open(0,"",0); return 0; } See, there's no -lc-client. I even did a "IMAP_SHARED_LIBADD=-lc-client ; export IMAP_SHARED_LIBADD" before calling configure and nothing changed.... I had various other build problems until I removed the --disable-rpath option from configure (--disable-rpath was there for "historical" reasons, read: because redhat used it in their spec file). The PEAR installation fails right at it's start: $ make install INSTALL_ROOT=/var/tmp/php-root [/bin/sh libtool command omitted for brevity] Installing PHP SAPI module Installing shared extensions: /var/tmp/php-root/usr/lib/php4/ Installing PHP CLI binary: /var/tmp/php-root/usr/bin/ Installing PEAR environment: /var/tmp/php-root/usr/share/pear/ Warning: SAFE MODE Restriction in effect. The script whose uid is 503 is not allowed to access /usr/share owned by uid 0 in /home/vogel/rpm/BUILD/php4-200207170600/pear/System.php on line 235 This last message is repeated _many_ times, with some "Warning: version_compare() expects parameter 2" messages interspersed. I can reproduce this in various ways (i. e. building using rpm or doing the same "by hand"; changing configure options did not help in any way). If you want to reproduce: environment is redhat linux 7.0 with all relevant updates from redhat installed. I don't want to build with a newer redhat release, because the target server, where the binary will get installed finally, has redhat 7.0, too (and -- you guess it -- I cannot update to a newer release because that's a "production" machine). And yes, ext/pgsql in snapshot 200207170600 builds. If you're interested, I can send you a complete log of the rpm build via email. I don't want to include it here because of it's size (over 500 kByte). Previous Comments: ------------------------------------------------------------------------ [2002-07-17 13:49:05] sniper@php.net Did the include_path issue get solved with the snapshot or not? This is development version, so there might always be some build problems, etc. Can you also explain which part of pear install does not honour INSTALL_ROOT? It works just fine here.. And the imap problem..what was in the config.log? It's most likely NOT any bug in configure but some problem in your system. ------------------------------------------------------------------------ [2002-07-17 12:59:43] vogel@folz.de Well, the php4-200207170000 snapshot (which was in the php4-latest tarball) does not build as an RPM. The most important problem (and the show stopper for now) is that the pear installation does not honor the INSTALL_ROOT variable. This defeats building the RPM as a non-root user. Please look at the spec file from Redhat's SRPMs (we use 7.0, 7.1 and 7.2) if you don't know what I mean. Other problems: o ext/imap does not build (configure: error: build test failed. Please check the config.log for details. Looks like a bug in configure: there's no -lc-client in the gcc command line in config.log.) o ext/pgsql does not build (seems fixed in the php4-200207170600 snapshot, will try tomorrow). o DOM support needs libxml version 2.4.14 (says configure), but I have only 2.4.2 and must stay with this, at least at the moment. ------------------------------------------------------------------------ [2002-07-16 14:18:59] sniper@php.net Try this snapshot: http://snaps.php.net/php4-latest.tar.gz ------------------------------------------------------------------------ [2002-07-16 09:40:54] jflemer@php.net There is another bug w/ include_path (#15374), and a temporary work around was to put this before any include: ini_set('include_path', ini_get('include_path')); Though if you have problems with prepend files, there probably isn't any place you could put this where it would get executed in time. =/ ------------------------------------------------------------------------ [2002-07-10 08:38:41] vogel@folz.de Upgrading to apache-1.3.26 made it worse again. Recompiling the php-4.2.1 module with apache-1.3.26 installed did not improve the situation. We have to restart the apache daemon daily to keep the error rate at a bearable, but still annoying, level. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/14401 -- Edit this bug report at http://bugs.php.net/?id=14401&edit=1

« previous php.bugs (#14535) next »