#50220 [NoF->Opn]: file_exists fails for files on network share
ID: 50220
User updated by: aiso at chawerim dot nl
Reported By: aiso at chawerim dot nl
-Status: No Feedback
+Status: Open
Bug Type: Filesystem function related
Operating System: win32 only - window xp
PHP Version: 5.3.0
Assigned To: pajoye
New Comment:
This bug is solved in the latest 5.3 (php-5.3-nts-win32-VC9-x86-latest
of 3-12-2009) version. Thanks
Previous Comments:
------------------------------------------------------------------------
[2009-11-26 01:00:02] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2009-11-18 22:50:58] pajoye@php.net
You can fetch the zip, uncompress it somewhere and try your script. Or
even use it inside IIS as well.
------------------------------------------------------------------------
[2009-11-18 21:17:30] aiso at chawerim dot nl
sorry, can't do: downloaded php-5.3-nts-win32-VC9-x86-latest.msi. But
got installation error: code 2711. Just after selected web server setup.
------------------------------------------------------------------------
[2009-11-18 15:15:17] pajoye@php.net
Please try using this snapshot:
http://snaps.php.net/php5.3-latest.tar.gz
For Windows:
http://windows.php.net/snapshots/
------------------------------------------------------------------------
[2009-11-18 14:55:48] aiso at chawerim dot nl
Description:
------------
file_exists() fails for files on network share. Although these files
can be perfectly read by e.g. file_get_contents(). So these files really
do exist!
file_exists() works without problems for files not on a share such as
'C:\Program Files\PHP\php.ini'.
Can reproduce also with '\\\\.HOST\\SHARED FOLDERS\\data\\php.ini'
Using php 5.3.0 (VC9 x86 Non Thread Safe (2009-Jun-30 08:52:54)) on
windows XP Pro SP3.
safe_mode is off.
This is tested on windows console (cmd.exe). User is admin and is
allowed to go and read files on this share.
Reproduce code:
---------------
$file = '//.HOST/SHARED FOLDERS/data/php.ini';
error_log(substr(file_get_contents($file),0,100));
if (file_exists($file)) {
error_log("does exist");
} else {
error_log("does not exist");
}
Expected result:
----------------
First 100 characters of php.ini file + 'does exist'
Actual result:
--------------
First 100 characters of php.ini file + 'does not exist'
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50220&edit=1
Thread (6 messages)