#50432 [Opn->Fbk]: setting for display_errors not being honored
| From: | pajoye@php.net | Date: | Wed, 09 Dec 2009 20:28:44 +0000 |
| Subject: | #50432 [Opn->Fbk]: setting for display_errors not being honored | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-145593@lists.php.net to get a copy of this message | ||
ID: 50432
Updated by: pajoye@php.net
Reported By: bill dot mcclendon at digiconllc dot com
-Status: Open
+Status: Feedback
Bug Type: Scripting Engine problem
Operating System: Windows Server 2008
PHP Version: 5.3.1
New Comment:
Are you sure the right php.ini is loaded?
Previous Comments:
------------------------------------------------------------------------
[2009-12-09 20:11:04] bill dot mcclendon at digiconllc dot com
Description:
------------
When using 5.3.1 for Windows (VC6 non thread safe) build, the php.ini
settings for "display_errors=Off" is ignored and E_NOTICE messages
display in the web page results from PHP.
This can also be seen via "phpinfo()" which shows the setting "On".
If I run "php -i " from the command window, the setting correctly shows
"Off".
Windows Server 2008
IIS 7.0
PHP 5.3.1 (binary .msi install from windows.php.net)
Reproduce code:
---------------
<? phpinfo();?>
Expected result:
----------------
display_errors Off
Actual result:
--------------
display_errors On
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50432&edit=1