#50448 [NEW]: Unable to load dynamic library 'c:/php/ext\\php_java.dll'
| From: | vsanam at 1fbusa dot com | Date: | Fri, 11 Dec 2009 07:49:41 +0000 |
| Subject: | #50448 [NEW]: Unable to load dynamic library 'c:/php/ext\\php_java.dll' | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-145629@lists.php.net to get a copy of this message | ||
From: vsanam at 1fbusa dot com
Operating system: Windows XP Professional 2002
PHP version: 5.3.1
PHP Bug Type: Dynamic loading
Bug description: Unable to load dynamic library 'c:/php/ext\\php_java.dll'
Description:
------------
I am using the following softwares installed in my application.
1. php-5.3.1-Win32-VC6-x86.ZIP
2. apache_2.2.14-win32-x86-no_ssl.msi
3. jdk1.5.0_13.
I have downloaded the file "JavaBridgeTemplate5541.war" from
"http://sourceforge.net/projects/php-java-bridge/files/Binary%20package/"
site and place the JavaBridge.jar from "JavaBridgeTemplate5541.war" into
"c:/php/ext". The file "php_java.dll" not found in the
"JavaBridgeTemplate5541.war" to place in the "c:/php/ext".
When I tried to restart and run the Apache http Server I unable to see the
"Java" option in the "php configuration options" with the following syntax:
<?php phpinfo(); ?> when run on the browser with the URL
"http://localhost/".
Reproduce code:
---------------
Configured the file "php.ini" with the following lines:
extension_dir = "c:/php/ext"
[java]
java.java_home = "C:/Program Files/Java/jdk1.5.0_13"
java.java = "C:/Program Files/Java/jdk1.5.0_13/bin/javaw.exe"
java.class.path = "C:/php/ext/JavaBridge.jar"
java.library.path = "C:/php/ext"
java.log_level=2
Expected result:
----------------
I should see the "Java" option when I run the
"index.php" file.
"index.php":
<?php
phpinfo();
?>
Java
Java Enabled: true;
Java Bridge: 5.5.4
Java status : running
Actual result:
--------------
This is the following error I can see in the "error log" file of the
appache http server.
PHP Warning: PHP Startup: Unable to load dynamic library
'c:/php/ext\\php_java.dll' - The specified module could not be found.\r\n
in Unknown on line 0
--
Edit bug report at http://bugs.php.net/?id=50448&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=50448&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=50448&r=trysnapshot53
Try a snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=50448&r=trysnapshot60
Fixed in SVN: http://bugs.php.net/fix.php?id=50448&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=50448&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=50448&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=50448&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=50448&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=50448&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=50448&r=support
Expected behavior: http://bugs.php.net/fix.php?id=50448&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=50448&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=50448&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=50448&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=50448&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=50448&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=50448&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=50448&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=50448&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=50448&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=50448&r=mysqlcfg