#50290 [Fbk->Bgs]: 5.3.1 iis fast cgi module time out on accessing mysql
ID: 50290
Updated by: pajoye@php.net
Reported By: praveen at aexea dot net
-Status: Feedback
+Status: Bogus
Bug Type: MySQL related
Operating System: vista business
PHP Version: 5.3.1
Assigned To: mysql
New Comment:
Doh.
"Un-commenting the line (127.0.0.1 localhost) seems to have fixed
the issue for now."
You have to do it. It is not an option.
Same configuration issue, as always > bogus.
Previous Comments:
------------------------------------------------------------------------
[2009-12-15 12:15:16] instinct644 at googlemail dot com
Id like to add, in Windows Server 2008 R2 the hosts file already had
both of the lines (127.0.0.1 and ::1) commented already, but it does
note (# localhost name resolution is handled within DNS itself.)
Un-commenting the line (127.0.0.1 localhost) seems to have fixed
the issue for now.
Is this going to be fixed in a future PHP release ? Or is it windows ?
------------------------------------------------------------------------
[2009-12-11 16:38:31] pajoye@php.net
Please disable IPv6 or set localhost correctly in your hosts file (not
::1, as said and explained already a good 100 times here) and try again.
Or use 127.0.0.1?
------------------------------------------------------------------------
[2009-12-11 16:36:32] praveen at aexea dot net
yes, i too downgraded to 5.3.0 because of this issue. I even tried
installing a latest snapshot on 25th Nov, but had the same issue..
------------------------------------------------------------------------
[2009-12-11 12:32:20] bramus at bram dot us
Same issue here (PHP 5.3.1 as a fastcgi module in IIS7). Getting
timeouts and HTTP 500 codes whenever I encounter a script that wants to
connect to a MySQL server.
Internal logging of my app tells me that the mysql(i)_connect function
fails: "Could not connect. A connection attempt failed because the
connected party did not properly respond after a period of time, or
established connection failed because connected host has failed to
respond."
After reverting to an older version of PHP (pre 5.3.1) all works fine
again.
@pajoye: sample code is really simple:
<?php
// this will fail in PHP 5.3.1 on IIS7 (fastcgi) even though the DB
server is up and the credentials are fine - Internal Server Error will
be spawn.
mysqli_connect('localhost', 'username', 'pass');
?>
Hope this helps.
Regards,
Bramus!
------------------------------------------------------------------------
[2009-12-03 01:00:00] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/50290
--
Edit this bug report at http://bugs.php.net/?id=50290&edit=1
Thread (8 messages)