#50489 [NEW]: SoapClient + HTTPs + Proxy = SSL errors
| From: | zamolxero at gmail dot com | Date: | Wed, 16 Dec 2009 10:21:10 +0000 |
| Subject: | #50489 [NEW]: SoapClient + HTTPs + Proxy = SSL errors | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-145784@lists.php.net to get a copy of this message | ||
From: zamolxero at gmail dot com
Operating system: Linux, Windows
PHP version: 5.2.11
PHP Bug Type: SOAP related
Bug description: SoapClient + HTTPs + Proxy = SSL errors
Description:
------------
Apache 2.x
PHP 5.2.11
'./configure' '--prefix=/usr/lib/php5' '--host=i686-pc-linux-gnu'
'--mandir=/usr/lib/php5/man' '--infodir=/usr/lib/php5/info'
'--sysconfdir=/etc' '--cache-file=./config.cache'
'--with-pcre-regex=/usr'
'--disable-cli' '--with-apxs2=/usr/sbin/apxs2'
'--with-config-file-path=/etc/php/apache2-php5'
'--with-config-file-scan-dir=/etc/php/apache2-php5/ext-active'
'--without-pear' '--disable-bcmath' '--with-bz2'
'--disable-calendar'
'--with-curl' '--without-curlwrappers' '--disable-dbase'
'--enable-exif'
'--without-fbsql' '--without-fdftk' '--disable-filter'
'--enable-ftp'
'--with-gettext' '--without-gmp' '--disable-ipv6'
'--without-kerberos'
'--enable-mbstring' '--with-mcrypt' '--with-mhash'
'--without-msql'
'--without-mssql' '--with-ncurses' '--with-openssl'
'--with-openssl-dir=/usr' '--enable-pcntl' '--without-pgsql'
'--without-pspell' '--without-recode' '--disable-shmop'
'--without-snmp'
'--enable-soap' '--enable-sockets' '--without-sybase'
'--without-sybase-ct'
'--disable-sysvmsg' '--disable-sysvsem' '--disable-sysvshm'
'--without-tidy' '--disable-wddx' '--disable-xmlreader'
'--disable-xmlwriter' '--with-xmlrpc' '--without-xsl'
'--enable-zip'
'--with-zlib' '--disable-debug' '--enable-dba'
'--without-cdb' '--with-db4'
'--disable-flatfile' '--with-gdbm' '--disable-inifile'
'--without-qdbm'
'--with-freetype-dir=/usr' '--with-t1lib=/usr' '--disable-gd-jis-conv'
'--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--without-xpm-dir'
'--with-gd' '--with-imap' '--with-imap-ssl' '--with-ldap'
'--without-ldap-sasl' '--with-mysql=/usr'
'--with-mysql-sock=/var/run/mysqld/mysqld.sock'
'--with-mysqli=/usr/bin/mysql_config' '--without-pdo-dblib'
'--with-pdo-mysql=/usr' '--without-pdo-odbc' '--without-pdo-pgsql'
'--without-pdo-sqlite' '--with-readline' '--without-libedit'
'--without-mm'
'--without-sqlite'
Reproduce code:
---------------
$SoapClient = new SoapClient(
$soap_url_.'?wsdl',
array(
'location' => $soap_url_,
'cache_wsdl' => WSDL_CACHE_NONE,
'user_agent' => __FUNCTION__,
'trace' => 1,
'exceptions' => 1,
'allow_self_signed' => 1,
'proxy_host' => $proxy_host,
'proxy_login' => $proxy_user,
'proxy_password' => $proxy_pass,
'proxy_port' => (int)$proxy_port
)
);
Expected result:
----------------
I expect everything to go smooth and fetch the WSDL file contents. I
tested the proxy manually on the https wsdl resource and it works.
Actual result:
--------------
Warning: SoapClient::SoapClient() [soapclient.soapclient]: SSL operation
failed with code 1. OpenSSL Error messages: error:140770FC:SSL
routines:SSL23_GET_SERVER_HELLO:unknown protocol in
/var/www/vhosts/site/connect-soap.php on line 138
Warning: SoapClient::SoapClient(https://secure.site.com/api/soap.php?wsdl)
[soapclient.soapclient]: failed to open stream: Cannot connect to HTTPS
server through proxy in /var/www/vhosts/site/connect-soap.php on line 138
Warning: SoapClient::SoapClient() [soapclient.soapclient]: I/O warning :
failed to load external entity "https://secure.site.com/api/soap.php?wsdl"
in /var/www/vhosts/site/connect-soap.php on line 138
--
Edit bug report at http://bugs.php.net/?id=50489&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=50489&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=50489&r=trysnapshot53
Try a snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=50489&r=trysnapshot60
Fixed in SVN: http://bugs.php.net/fix.php?id=50489&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=50489&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=50489&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=50489&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=50489&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=50489&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=50489&r=support
Expected behavior: http://bugs.php.net/fix.php?id=50489&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=50489&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=50489&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=50489&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=50489&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=50489&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=50489&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=50489&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=50489&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=50489&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=50489&r=mysqlcfg