#50561 [Opn->WFx]: Big issue when using APC
| From: | johannes@php.net | Date: | Wed, 23 Dec 2009 15:52:38 +0000 |
| Subject: | #50561 [Opn->WFx]: Big issue when using APC | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-146069@lists.php.net to get a copy of this message | ||
ID: 50561
Updated by: johannes@php.net
Reported By: sebastien dot geoffroy-1 at laposte dot net
-Status: Open
+Status: Wont fix
Bug Type: Dynamic loading
Operating System: Windows 2000
PHP Version: 6SVN-2009-12-23 (SVN)
New Comment:
We are sorry, but we can not support PHP 4 related problems anymore.
Momentum is gathering for PHP 6, and we think supporting PHP 4 will
lead to a waste of resources which we want to put into getting PHP 6
ready.
Previous Comments:
------------------------------------------------------------------------
[2009-12-23 15:41:47] sebastien dot geoffroy-1 at laposte dot net
Description:
------------
Hi,
My platform:
- Apache 2.0.55
- PHP: 4.4.1
- apc 3.0.19
- OS Windows 2000 SP4
I can't upgrade one of them because of application's prerequesite.
I took apc binary here :http://downloads.php.net/pierre/ and I choosed
this one: php_apc-3.0.19-5.2-Win32-VC6-x86.zip (containing php_apc.dll
Version 5.2.9.9).
I try to turn on APC cache on my system.
Into php.ini file I added:
extension = php_apc.dll
[APC]
apc.enabled = 1
When starting apache I get on error log file:
PHP Warning: Unknown(): Unable to load dynamic library './php_apc.dll'
- Le module sp\xe9cifi\xe9 est introuvable.\r\n in Unknown on line 0
I tried to add this into httpd conf file:
LoadModule apc_module "c:/program files/php/sapi/php_apc.dll"
But same similar thing:
[Wed Dec 23 16:14:30 2009] [notice] Apache/2.0.55 (Win32) PHP/4.4.1
mod_ssl/2.0.55 OpenSSL/0.9.8 configured -- resuming normal operations
[Wed Dec 23 16:14:30 2009] [notice] Server built: Oct 9 2005 19:16:56
[Wed Dec 23 16:14:30 2009] [notice] Parent: Created child process 956
Syntax error on line 107 of C:/Program Files/Apache
Group/Apache2/conf/httpd.conf:
Cannot load C:/Program Files/PHP/sapi/php_apc.dll into server: Le
module sp\xe9cifi\xe9 est introuvable.
[Wed Dec 23 16:14:30 2009] [crit] master_main: create child process
failed. Exiting.
[Wed Dec 23 16:14:30 2009] [notice] Parent: Forcing termination of
child process 2342432
What I did wrong? I would really apreciate your help on this problem.
Regards.
Sebastien
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=50561&edit=1