#50433 [Com]: mysql extensions don't work
ID: 50433
Comment by: ewal at pointpro dot nl
Reported By: darkdominiongr at gmail dot com
Status: Open
Bug Type: MySQL related
Operating System: win32 only - Windows 7 x64
PHP Version: 5.3.1
New Comment:
I can confirm this problem; first ran into it on a Windows 2008 R2
server x64 and then confirmed on a Windows 7 x64 machine. It does work
in 5.3.0.
Previous Comments:
------------------------------------------------------------------------
[2009-12-14 21:50:57] SKJoy2001 at InBox dot Com
System: Intel Core i7 with 2x3 DDR III
OS: Microsoft Windows 7 Ultimate
Web server: IIS 7.5
PHP: 5.3.1 (CGI)
PHPMyAdmin fails to load but the native 'mysql_connect' &
'mysql_select_db' is working fine on test scripts.
------------------------------------------------------------------------
[2009-12-12 19:01:41] darkdominiongr at gmail dot com
Can someone verify this on a Windows server?
------------------------------------------------------------------------
[2009-12-10 07:03:06] jani@php.net
Some windows issue, on *nix everything works just fine.
------------------------------------------------------------------------
[2009-12-09 23:13:59] darkdominiongr at gmail dot com
<?php
$host = "******";
$username = "******";
$password = "******";
mysql_connect("$host","$username","$password") or
die("couldn't
establish connection: " . mysql_error());
echo "Connected to MySQL";
?>
When i try this code in php 5.3.0 i get the "connected to mysql"
message correctly. But when i try it on 5.3.1 i get the following
message.
couldn't establish connection: A connection attempt failed because the
connected party did not properly respond after a period of time, or
established connection failed because connected host has failed to
respond.
------------------------------------------------------------------------
[2009-12-09 21:54:08] pajoye@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves.
A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external
resources such as databases, etc. If the script requires a
database to demonstrate the issue, please make sure it creates
all necessary tables, stored procedures etc.
Please avoid embedding huge scripts into the report.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/50433
--
Edit this bug report at http://bugs.php.net/?id=50433&edit=1
Thread (10 messages)