Bug #18448 Updated: __cmpdi2: referenced symbol not found

From: Date: Sat, 20 Jul 2002 16:20:31 +0000
Subject: Bug #18448 Updated: __cmpdi2: referenced symbol not found
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-14697@lists.php.net to get a copy of this message
ID: 18448 Updated by: sniper@php.net Reported By: scott.white@sun.com Status: Feedback -Bug Type: Apache related +Bug Type: Compile Failure Operating System: Solaris 9 PHP Version: 4.2.1 Previous Comments: ------------------------------------------------------------------------ [2002-07-20 12:20:00] sniper@php.net Try adding this --enable-libgcc to your php configure line. ------------------------------------------------------------------------ [2002-07-20 09:24:28] scott.white@sun.com I am trying to compile PHP on Solaris 9 with the shipping version of Apache in a similar manor to Solaris 8 http://www.bolthole.com/solaris/php+solaris.html When I start Apache I get the following error bash-2.05# /usr/apache/bin/apachectl start Syntax error on line 249 of /etc/apache/httpd.conf: Cannot load /usr/apache/libexec/libphp4.so into server: ld.so.1: /usr/apache/bin/httpd: fatal: relocation error: file /usr/apache/libexec/libphp4.so: symbol __cmpdi2: referenced symbol not found /usr/apache/bin/apachectl start: httpd could not be started I have tried PHP 4.2.1, php4-200207191800, and php4-STABLE-200207191800. I have tried 3.1 and gcc 2.95.3 The Solaris bundled version of Apache is 1.3.22 and is compiled configured by Sun as such ./configure --with-layout=Solaris \ --prefix=/usr/apache \ --with-perl=/usr/perl5/bin/perl \ --verbose \ --enable-module=all \ --disable-module=auth_db \ --enable-rule=EAPI \ --enable-rule=SHARED_CORE \ --enable-rule=SHARED_CHAIN \ --bindir=/usr/apache/bin \ --sbindir=/usr/apache/bin \ --libexecdir=/usr/apache/libexec \ --mandir=/usr/apache/man \ --sysconfdir=/etc/apache \ --datadir=/var/apache \ --includedir=/usr/apache/include \ --cgidir=/var/apache/cgi-bin \ --localstatedir=/usr/apache I configure php as follows bash-2.05# export CC; CC=gcc bash-2.05# which gcc /usr/local/bin/gcc bash-2.05# ./configure --with-apxs=/usr/apache/bin/apxs --with-zlib=/usr --with-db3=/opt/sfw --with-openssl=/usr/local/ssl --with-mysql=/opt/sfw/mysql bash-2.05# make install I have also changed libexec/somemodule.so to /usr/apache/libexec/somemodule throughout the httpd.conf PHP compiles as expected and installs, but when I issue /usr/apache/bin/apachectl start I get the error /usr/apache/libexec/libphp4.so: symbol __cmpdi2: referenced symbol not found my http user has a .profile as follows PATH=/bin:/usr/bin:/usr/X11R6/bin:/usr/dt/bin:/usr/openwin/bin:/usr/local/bin:/sbin:/usr/sbin:/usr/games:/opt/sfw/bin:/home/sw25481/bin:/usr/ccs/bin MANPATH=/usr/share/man:/usr/local/man:/usr/local/share/man:/opt/sfw/man JAVA_HOME=/usr/java LD_LIBRARY_PATH=/usr/local/lib:/usr/local/ssl/lib:/opt/sfw/lib:/opt/sfw/mysql/lib/mysql:/usr/local/lib/gcc-lib/sparc-sun-solaris2.9/3.1 export PATH MANPATH JAVA_HOME I have tried setting roots LD_LIBRARY_PATH the same as http with no change. The system is a dual processor Ultra2 with 750M memory, running Solaris 9 GA with the latest patch bundle which consists of the following patches 108127-05, 112785-04, 112875-01 Please let me know if I can offer any more information or test any possible solutions. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18448&edit=1

« previous php.bugs (#14697) next »