Bug #18426 Updated: Problem with Ingres II 2.6
| From: | vg3005 at club-internet dot fr | Date: | Sat, 20 Jul 2002 23:33:36 +0000 |
| Subject: | Bug #18426 Updated: Problem with Ingres II 2.6 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-14707@lists.php.net to get a copy of this message | ||
ID: 18426
Updated by: vg3005@club-internet.fr
Reported By: vg3005@club-internet.fr
-Status: Feedback
+Status: Open
Bug Type: *Database Functions
Operating System: Mandrake linux 8.2 2.4.18.6
PHP Version: 4.2.1
New Comment:
I try to compile php with apxs as it'swrite in file INSTALL, the module
libphp4.so is created and install in correct directory but when I tryed
to start apache it failled on loading libphp4.so:
Syntax error on line 206 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/apache/libexec/libphp4.so: undefined symbol:
pthread_mutex_trylock
./apachectl start: httpd could not be started
I Have install Advantage Ingres 2.6 for linux (The Cd was send by
Computer assciates with 1 month licence). I have select full package
install.
Previous Comments:
------------------------------------------------------------------------
[2002-07-18 19:30:08] sniper@php.net
The first problem is not any bug, from INSTALL:
.
.
$ cd ../apache_1.3.x
$ ./configure --prefix=/www
--activate-module=src/modules/php4/libphp4.a
(The above line is correct! Yes, we know libphp4.a does
not exist at this stage. It isn't supposed to. It will be
created.)
Please follow the instruction given in the INSTALL file..
and if you still get the same problem, let us know which version of
ingress you get this with (and where we can get the same package)
------------------------------------------------------------------------
[2002-07-18 18:38:59] vg3005@club-internet.fr
What I do:
gunzip apache_1.3.x.tar.gz
tar xvpzf apache_1.3.26.tgz
gunzip php-4.2.1.tgz
cd apache_1.3.26
./configure --prefix=/apache
cd ../php-4.2.1
./configure --with-mysql --with-apache=../apache_1.3.26
--enable-track-vars --with-ingres=/home/ingresII/ingres
make
make install
cd ../apache_1.3.26
./configure --activate-module=src/modules/php4/libphp4.a
make
first probleme the installation of php don't copy libphp4.a into
apache_1.3.26/src/modules/php4 so I get it from php4/libs directory
but now when I try to compile Apache 1.3.26 with php 4.2.1 with support
of mysql and ingres II 2.6 I get this message
/home/ingresII/ingres/lib/libingres.a(louniq.o): In function `LOuniq':
louniq.o(.text+0x16d): the use of `mktemp' is dangerous, better use
`mkstemp'
/home/ingresII/ingres/lib/libingres.a(mepages.o): In function
`IIMEget_pages':
mepages.o(.text+0x1c5): undefined reference to `pthread_mutex_trylock'
collect2: ld returned 1 exit status
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=18426&edit=1