Bug #51079 [Com]: fsockopen will not work on 'localhost'
| From: | thijsputman at gmail dot com | Date: | Wed, 10 Mar 2010 11:31:15 +0000 |
| Subject: | Bug #51079 [Com]: fsockopen will not work on 'localhost' | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-148464@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=51079&edit=1
ID: 51079
Comment by: thijsputman at gmail dot com
Reported by: tony at marston-home dot demon dot co dot uk
Summary: fsockopen will not work on 'localhost'
Status: Assigned
Type: Bug
Package: Sockets related
Operating System: win32 only - Windows XP
PHP Version: 5.2.12
Assigned To: pajoye
New Comment:
Fair enough :)
The reproduce code provided fails to connect to "localhost" with
fsockopen() in PHP 5.3.2. When using PHP 5.3.0 fsockopen() connects to
"localhost" without problems.
Previous Comments:
------------------------------------------------------------------------
[2010-03-10 12:03:59] pajoye@php.net
It does not depend on PHP only but libmysql or mysql server. Please keep
posting about the socket issue only here as the myslq&IPv6 questions
have been covered numerous times in other reports. The one report per
issue rule is also a good way to do not get distracted, thanks for your
understanding :)
------------------------------------------------------------------------
[2010-03-10 11:38:07] thijsputman at gmail dot com
Agreed, but that's not my point:
Just like when using fsockopen() to connect to "localhost", I would
expect mysql_connect("localhost") to also attempt to use IPv4,
irrespective of whether "localhost" resolves to [::1] or 127.0.0.1.
This is the same behaviour exhibited by Firefox on my system and
apparently also the behaviour of several other PHP functions, as made
clear in the initial post of this bug.
------------------------------------------------------------------------
[2010-03-10 10:53:40] pajoye@php.net
Mysql is not related to this problem, IPv6 is not supported and you have
to apply one of the solutions described here or one of the other
numerous reports about mysql and IPv6.
------------------------------------------------------------------------
[2010-03-10 09:43:16] thijsputman at gmail dot com
I can confirm that the problem is not present in PHP 5.3.0, but _is_
present in PHP 5.3.2...
It appears the mysql(i) extension is suffering from the same issue: I
just spend a couple hours going through various versions of phpMyAdmin
(which after upgrading from 5.3.0 simply timed out with a blank page)
until discovering this issue. Changing "localhost" into "127.0.0.1" did
trick.
Tested using 5.3.2 (VC9 NTS) on Windows Server 2008 (x64). On a side
note, both Firefox and MS telnet don't have any issues connecting to
localhost over IPv4.
------------------------------------------------------------------------
[2010-02-19 14:42:07] tony at marston-home dot demon dot co dot uk
-Status: Feedback
+Status: Open
I have tried 5.2.13RC2, but it produces the same error. I have not tried
5.3.2RC2 as I do not have an error with 5.3.0 (which may be because my
copy of 5.3.0 does not have IPv6 support enabled).
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/bug.php?id=51079
--
Edit this bug report at http://bugs.php.net/bug.php?id=51079&edit=1