Bug #51270 [Com]: Apache cannot start
| From: | a at liveb dot ru | Date: | Thu, 11 Mar 2010 13:21:22 +0000 |
| Subject: | Bug #51270 [Com]: Apache cannot start | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-148513@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=51270&edit=1
ID: 51270
Comment by: a at liveb dot ru
Reported by: jamone_95134 at yahoo dot com
Summary: Apache cannot start
Status: Open
Type: Bug
Package: Apache2 related
Operating System: Windows XP SP3
PHP Version: 5.3.2
New Comment:
Have the same problem. apache doesn't work as a service. But works from
console.
When I try to start the service I get an error.
szAppName : httpd.exe szAppVer : 2.2.15.0 szModName : unknown
szModVer : 0.0.0.0 offset : 0073d729
Previous Comments:
------------------------------------------------------------------------
[2010-03-11 02:30:07] jamone_95134 at yahoo dot com
Description:
------------
php was installed and works correctly, php 5.3.2 thread safe VC6
version.
Apache version 2.2.15 with openssl. The Apache was installed and works.
However, when I try to have Apache run and recognize the PHP, the Apache
does not start and displays the following message:
httpd.exe - Application Error
The instruction at "0x00788ce1" referenced memory at "0x00000006". The
memory could not be "read".
If I comment out the lines referring to the PHP in the httpd.conf file,
then Apache starts with no problems.
#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
#PHPIniDir "C:/Program Files/PHP/"
#LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
If either line is mot commented, then the Apache crashes.
I have tried commenting out the different extensions in the php.ini
file, but the problem exists.
Can someone please explain why this is crashing and what to do to fix
it.
Expected result:
----------------
Apache to start up and recognize php scripting.
Actual result:
--------------
httpd.exe - Application Error
The instruction at "0x00788ce1" referenced memory at "0x00000006". The
memory could not be "read".
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=51270&edit=1