Bug #11058 [Com]: php_network_getaddresses: getaddrinfo failed
| From: | cha0s at therealcha0s dot net | Date: | Thu, 25 Mar 2010 05:28:07 +0000 |
| Subject: | Bug #11058 [Com]: php_network_getaddresses: getaddrinfo failed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-148979@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=11058&edit=1
ID: 11058
Comment by: cha0s at therealcha0s dot net
Reported by: pat at mail dot rit dot edu
Summary: php_network_getaddresses: getaddrinfo failed
Status: Bogus
Type: Bug
Package: Network related
Operating System: OpenBSD 2.6
PHP Version: 4.0.6
New Comment:
Still present in 5.3.
Previous Comments:
------------------------------------------------------------------------
[2009-04-08 05:37:11] avenger@php.net
I have this problem on RHEL5 too.
My sloved is "chmod 644 /etc/hosts"
Simple,but useful for me.
------------------------------------------------------------------------
[2004-09-27 19:06:52] rowaldru at gpi dot com
I am currently on 4.3.8. Has this issue been addressed and fixed in
5.0.1?
------------------------------------------------------------------------
[2004-08-21 14:38:39] webmaster at hg-carstyling dot de
ages later, i found a solution, what solves it for me here.
the problem seems to base on the name resolution for the remote
machine.
a typical error while opening a remote file was:
----
Warning: fsockopen(): php_network_getaddresses: getaddrinfo failed:
Name or service not known in
/home/carstyling/public_html/newnuke/modules/WebMail/pop3.php on line
70
Warning: fsockopen(): unable to connect to mx.freenet.de:110 in
/home/carstyling/public_html/newnuke/modules/WebMail/pop3.php on line
70
----
i tryed to reconfigure my named configuration, without any result, to
fix this.
the problem was solved by adding the following line to my /etc/hosts:
194.97.55.147 mx.freenet.de
i have to do this for any remote machine i like to open files on.
this is NOT the basic of that problem, but patches arround that. i was
not able, to tell my named, to resolv that adress to that ip, so i have
to enter that in /etc/hosts .
it seems, the problem is the name-resolution domain to ip, as it was
discribed already here and on other sources before.
over that, it is not a problem of all your php-scripts, you`ve written
and were the error comes. just enter the unknown machine to your hosts
file and all went fine.
i tryed many different configurations of my bind, but was not able, to
resolve other top level domains within a full qualified domain name so i
feel to say its a bug in bind by isc, but this can also be a security
relatet problem.
i am open for mail and requests and i am very interrested on the basic
solution.
regardz :)
------------------------------------------------------------------------
[2004-08-16 01:40:43] hachem at phptunisia dot com
restart the bind
------------------------------------------------------------------------
[2004-07-14 22:29:05] neil dot giarratana at lucidus dot net
Don't know if this helps at all but on RH9, if I do a "service network
restart", all is well again and I don't get that error anymore. Beats
the heck out of restarting the whole server
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/bug.php?id=11058
--
Edit this bug report at http://bugs.php.net/bug.php?id=11058&edit=1