Bug #16906 Updated: Warning: MySQL: Unable to save result set in ...

From: Date: Tue, 23 Jul 2002 19:51:19 +0000
Subject: Bug #16906 Updated: Warning: MySQL: Unable to save result set in ...
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-14940@lists.php.net to get a copy of this message
ID: 16906 Updated by: bugs.php@computer.NOSPAM.creations.nl Reported By: vermut@aija.net Status: Assigned Bug Type: MySQL related Operating System: FreeBSD PHP Version: 4.1.2, 4.2.0 Assigned To: cynic New Comment: I've got the same error on the webserver of my hosting provider (Linux 2.4.13) using PHP 4.2.2 when updating/inserting records to MySQL (client 3.23.39). Also a simple select of all records (approx. 3750 records, 479Kb in total as line-delimited text) Anyone got an idea how to solve this? If you respond, please connect computer and creations in my emailaddress. Previous Comments: ------------------------------------------------------------------------ [2002-07-02 14:53:17] cynic@php.net umm, I should've added that I've encountered something like this just yesterday with 4.1.2/1.3.24, 4.2.1/1.3.24 and 4.2.1/1.3.26, but that was on RH 7.2. and the error mesage was different. all updates from php were corrupting the tables. updates from mysql(1) were ok. eventually it got fixed by dumping, dropping, and recreating the table. but that's probably completely unrelated. ------------------------------------------------------------------------ [2002-07-02 14:32:40] cynic@php.net this works with 4.3.0-dev, I'll have to try 4.2.1 tomorrow. roman@freepuppy ~/install/php4 > cat ./config.nice.cli+apxs 192:0 #! /bin/sh # # Created by configure './configure' \ '--enable-cli' \ '--enable-inline-optimization' \ '--enable-ftp' \ '--enable-shmop' \ '--enable-sysvsem' \ '--enable-sysvshm' \ '--enable-sockets' \ '--enable-tokenizer' \ '--disable-session' \ '--disable-shared' \ '--with-apxs=/usr/local/sbin/apxs' \ '--with-openssl' \ '--with-zlib' \ '--with-bz2' \ '--with-curl' \ '--with-gettext' \ '--with-iconv' \ '--with-mcrypt=/usr/local' \ '--with-mhash=/usr/local' \ '--with-ncurses' \ '--with-readline' \ '--with-pear' \ '--with-config-file-path=/usr/local/etc' \ '--with-mysql=/usr/local' \ "$@" <? mysql_connect('localhost', 'root', ''); mysql_select_db('mysql'); $rs = mysql_query("UPDATE user set user='root' where user='root'"); if (!$rs) printf("%d: %s\n\n", mysql_errno(), mysql_error()); else print("all clear\n\n"); output: all clear ------------------------------------------------------------------------ [2002-05-02 13:24:13] vermut@aija.net As I said - every update query fails. I use this example: <?php define ("DB_HOST","localhost"); define ("DB_LOGIN","root"); define ("DB_PSW","password"); define ("DB_NAME","mysql"); mysql_connect(DB_HOST,DB_LOGIN,DB_PSW); mysql_select_db(DB_NAME); mysql_query("UPDATE user set user='root' where user='root'"); ?> Query, executed directly in mysql, works. ------------------------------------------------------------------------ [2002-05-02 06:34:30] sniper@php.net Please add SHORT but complete example script to this report which can be used to reproduce this. --Jani ------------------------------------------------------------------------ [2002-05-01 05:31:49] vermut@aija.net The problem is: _every_ UPDATE query executed from PHP reports this warning. Data become updated, but execution stops. The same query executed in plain mysql does the same, but does not report a warning. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/16906 -- Edit this bug report at http://bugs.php.net/?id=16906&edit=1

« previous php.bugs (#14940) next »