Bug #17554 Updated: Library file not found
| From: | David_Pottier at Shaw dot Ca | Date: | Tue, 23 Jul 2002 20:17:14 +0000 |
| Subject: | Bug #17554 Updated: Library file not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-14943@lists.php.net to get a copy of this message | ||
ID: 17554
Updated by: David_Pottier@Shaw.Ca
Reported By: regan@protonic.com
Status: Bogus
Bug Type: Apache2 related
Operating System: Windows 98
PHP Version: 4.2.1
New Comment:
I have had the same problem with both Apache 1.3 and 2
However with php4apache2.dll the error code was an even more severe
problem with the way php4apache2.dll was compiled
Does anyone have the solution to the original problem that regan
posted?
Previous Comments:
------------------------------------------------------------------------
[2002-06-01 13:11:44] edink@php.net
It's in the PHP 4.2.1 zip distribution.
------------------------------------------------------------------------
[2002-06-01 13:05:39] regan@protonic.com
Where do I obtain that file?
------------------------------------------------------------------------
[2002-06-01 13:04:11] edink@php.net
You should use php4apache2.dll for Apache 2.
------------------------------------------------------------------------
[2002-06-01 12:55:39] regan@protonic.com
I installed Apache 2 which runs fine on it's own but when I installed
PHP as a module and I try and run my Apache 2 server I get the
following error:
Syntax error on line 738 of C:/Programs Files/Apache
Group/Apache2/conf/httpd.conf:
Cannot load C:/Server Apps/PHP/sapi/php4apache.dll into server: One of
the library files needed to run this application cannot be found.
I am almost 100% sure that I have installed every file that is needed.
I downloaded the binary files for W32 and followed the instructions to
the dot. I also installed the lastest ODBC updates, etc from
Microsoft.
The line that causes this error is:
LoadModule php4_module "C:/Server Apps/PHP/php4apache.dll"
AddModule mod_php4.c
AddType application/x-httpd-php .php
I don't understand if this is human error or if it is infact a bug.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=17554&edit=1