Bug #51594 [Opn->Fbk]: open_basedir reports fatal error within allowed path
Edit report at http://bugs.php.net/bug.php?id=51594&edit=1
ID: 51594
Updated by: felipe@php.net
Reported by: daniel at produktion203 dot se
Summary: open_basedir reports fatal error within allowed path
-Status: Open
+Status: Feedback
Type: Bug
Package: Safe Mode/open_basedir
Operating System: FreeBSD 8.0-RELEASE-p2
PHP Version: 5.3.2
New Comment:
Please try using this snapshot:
http://snaps.php.net/php5.3-latest.tar.gz
For Windows:
http://windows.php.net/snapshots/
Previous Comments:
------------------------------------------------------------------------
[2010-04-19 00:01:37] daniel at produktion203 dot se
Description:
------------
There seems to be some problem with open_basedir in php 5.3.2 for
freebsd, i used the 5.2 branch before and the exact same config worked
fine then.
open_basedir reports failure eventhough im within the allowed paths
Include paths in php.ini:
include_path = ".:/usr/local/share/pear:/usr/local/lib/php/include"
Testhost in apache:
<VirtualHost *:80>
DocumentRoot "/home/customers/produktion203/testin.se"
ServerName testin.se
php_admin_value open_basedir
/home/customers/produktion203/testin.se:/usr/local/share/pear:/usr/local/lib/php/include:/var/tmp
</VirtualHost>
Test script:
---------------
<?php
phpinfo();
Expected result:
----------------
Show the phpinfo();
Actual result:
--------------
Warning: Unknown: open_basedir restriction in effect. File() is not
within the allowed path(s):
(/home/customers/produktion203/testin.se:/usr/local/share/pear:/usr/local/lib/php/include:/var/tmp)
in Unknown on line 0
Fatal error: Can't load /home/customers/produktion203/testin.se/nfo.php,
open_basedir restriction. in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=51594&edit=1
Thread (6 messages)