Bug #51298 [Com]: Error when loading php5apache2_2.dll
| From: | sridhar dot devulkar at roost dot com | Date: | Thu, 03 Jun 2010 20:14:17 +0000 |
| Subject: | Bug #51298 [Com]: Error when loading php5apache2_2.dll | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-151066@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=51298&edit=1
ID: 51298
Comment by: sridhar dot devulkar at roost dot com
Reported by: trotsky_icepick at hotmail dot com
Summary: Error when loading php5apache2_2.dll
Status: Assigned
Type: Bug
Package: Apache2 related
Operating System: Windows Vista SP2
PHP Version: 5.3.2
Assigned To: pajoye
New Comment:
I had the same issue and was resolved by doing the same thing that
"peter dot martin at spam dot la" did.
All it was needed was to load php5ts.dll and libpq.dll through Apache.
Now accessing the php script from the command line as well as from the
web page works like a charm.
BTW, my setup is this:
Operating System: Windows Vista
Apache: Apache 2.2.11
PHP: php-5.3.2-Win32-VC6-x86.zip
Thanks,
Sri.
Previous Comments:
------------------------------------------------------------------------
[2010-05-30 08:49:56] chris dot groothoff at mbits dot com dot au
Just to let you know that the suggestion to install the ZIP version
(thread safe version) of the installation + manual configuration does
allow it to work properly. This would seem to suggest that it seem that
the MSI installer version is doing some thing during the install. If I
get a chance to pule the MSI apart, it may reveal the what it is trying
to do.
I have tested version 5.2.3 and 5.2.13, both work fine when installed
from the ZIP file.
BTW - I have resorted to using 5.2.13 as it contains the PHP_SNMP.DLL
that was required to run CACTI as I am not sure where to get a version
for 5.2.3.
------------------------------------------------------------------------
[2010-05-28 00:21:54] pajoye@php.net
Please, really, stop to add completely unrelated comments to this
issue.
This bug is clearly identified, there is a thread safe issue with the
date initialization. Every recent comments about missing DLLs are not
crashes but bad configurations.
------------------------------------------------------------------------
[2010-05-28 00:19:33] ppylak at gmail dot com
Supplement to my previous post.
I've added to c:\PHP\ such dlls (from pgAdmin III 1.10 installation):
gssapi32.dll,
comerr32.dll,
krb5_32.dll,
libintl-8.dll,
libiconv-2.dll,
k5sprt32.dll
and line
Loadfile "C:/PHP/libpq.dll"
to httpd.conf and my Apache has started with no changes to php.ini.
------------------------------------------------------------------------
[2010-05-28 00:01:49] ppylak at gmail dot com
In my opinion this problem is connected with loading libpq.dll, which
(in present
version) needs some other dlls to work, but these dlls aren't included
in php MSI
installer (and even in zip).
------------------------------------------------------------------------
[2010-05-27 19:04:33] chris dot groothoff at mbits dot com dot au
I have been struggling with te hsame issue on a W2K3 Server SP2. AS soon
as you install the PHP 5.3.2 VC9 or V6 version the Apache server fails
to start. the event log show the following error - Faulting application
httpd.exe, version 2.2.15.0, faulting module php5ts.dll, version
5.3.2.0, fault address 0x000e6d2c. I have also tryied the 5.2.13 VC6
version and this also gives teh same error.
I am going to try the ZIP solution suggested, but I can see why people
frefer the MSI version :-)
I did try to locate an earlier version of Apache V2.0.X, but can not
find a binary download.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/bug.php?id=51298
--
Edit this bug report at http://bugs.php.net/bug.php?id=51298&edit=1