Bug #48614 [Com]: Loading "pdo_sqlite.so" fails: undefined symbol: sqlite3_libversion

From: Date: Tue, 08 Jun 2010 10:52:21 +0000
Subject: Bug #48614 [Com]: Loading "pdo_sqlite.so" fails: undefined symbol: sqlite3_libversion
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-151179@lists.php.net to get a copy of this message
Edit report at http://bugs.php.net/bug.php?id=48614&edit=1

 ID:               48614
 Comment by:       kontakt at beberlei dot de
 Reported by:      kaspernj at gmail dot com
 Summary:          Loading "pdo_sqlite.so" fails: undefined symbol:
                   sqlite3_libversion
 Status:           Assigned
 Type:             Bug
 Package:          PDO related
 Operating System: Ubuntu Jaunty
 PHP Version:      5.3.0RC4
 Assigned To:      scottmac

 New Comment:

You can get this working with the following configure:

--without-sqlite --with-sqlite3=shared --with-pdo-sqlite=shared,/usr

More information in this thread: http://news.php.net/php.pdo/427


Previous Comments:
------------------------------------------------------------------------
[2010-05-25 23:50:30] ashoat at gmail dot com

The problem is still occurring. There really ought to be a patch by now.

------------------------------------------------------------------------
[2010-04-25 13:00:18] ovidio dot balan at gmail dot com

lol .. :(

------------------------------------------------------------------------
[2010-04-05 15:41:51] koubel at volny dot cz

Year will be gone, and problem is still here: tested on 5.3.2 debian
stable

------------------------------------------------------------------------
[2010-02-23 03:54:27] l27n at yahoo dot com

Same problem, PHP 5.3.1, CENTOS 5.4

------------------------------------------------------------------------
[2010-02-02 09:40:03] marc dot bennewitz at giata dot de

I have the same problem with suse 10.x 32/64 bit using php 5.3.0/1
stable.

My configure is:
cd "/home/worker/download/php-5.3.1"
./configure \
        --with-apxs2=/usr/local/apache2/bin/apxs \
        --with-mm \
        --with-mysql=shared,/usr/local \
        --with-mysqli=shared,/usr/local/bin/mysql_config \
        --with-sqlite=shared \
        --with-sqlite3=shared \
        --enable-pdo=shared \
        --with-pdo-mysql=shared,/usr/local \
        --with-pdo-sqlite=shared \
        --with-libxml-dir=/usr/local/lib \
        --enable-soap \
        --with-zlib \
        --disable-cgi \
        --with-gd=shared \
        --with-freetype-dir \
        --with-jpeg-dir=/usr/lib \
        --enable-gd-native-ttf \
        --enable-exif \
        --with-xsl \
        --with-mcrypt \
        --with-openssl \
        --enable-mbstring \
        --enable-mbregex \
        --enable-ftp=shared \
        --with-kerberos \
        --enable-zip

And extension order:
extension=pdo.so
extension=sqlite.so
extension=sqlite3.so
extension=mysql.so
extension=mysqli.so
extension=pdo_mysql.so
extension=pdo_sqlite.so

Additionally if I load sqlite.so before pdo.so than I get 1 more error:
PHP Warning:  PHP Startup: Unable to load dynamic library
'/usr/local/lib/php/extensions/no-debug-non-zts-20090626/sqlite.so' -
/usr/local/lib/php/extensions/no-debug-non-zts-20090626/sqlite.so:
undefined symbol: php_pdo_unregister_driver in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library
'/usr/local/lib/php/extensions/no-debug-non-zts-20090626/sqlite.so' -
/usr/local/lib/php/extensions/no-debug-non-zts-20090626/sqlite.so:
undefined symbol: php_pdo_unregister_driver in Unknown on line 0

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    http://bugs.php.net/bug.php?id=48614


-- 
Edit this bug report at http://bugs.php.net/bug.php?id=48614&edit=1


Thread (31 messages)

« previous php.bugs (#151179) next »