Bug #18567: symbol ldap_start_tls_s: referenced symbol not found
| From: | rwilliams at dynamicsoft dot com | Date: | Thu, 25 Jul 2002 16:01:20 +0000 |
| Subject: | Bug #18567: symbol ldap_start_tls_s: referenced symbol not found | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-15205@lists.php.net to get a copy of this message | ||
From: rwilliams@dynamicsoft.com
Operating system: Solaris 7
PHP version: 4.2.2
PHP Bug Type: *Configuration Issues
Bug description: symbol ldap_start_tls_s: referenced symbol not found
When attempting to start Apache 1.3.26 with PHP 4.2.2 compiled as an SO I
get the following error
# /etc/rc2.d/S95httpd start
Syntax error on line 219 of /export/apps/apache/conf/httpd.conf:
Cannot load /export/apps/apache/libexec/libphp4.so into server: ld.so.1:
/export/apps/apache/bin/httpd: fatal: relocation error: file
/export/apps/apache/libexec/libphp4.so: symbol ldap_start_tls_s:
referenced symbol not found
/etc/rc2.d/S95httpd start: httpd could not be started
This is the offending line in my httpd.conf file.
LoadModule php4_module libexec/libphp4.so
The ldd output
# ldd libphp4.so
libdl.so.1 => /usr/lib/libdl.so.1
libpam.so.1 => /usr/lib/libpam.so.1
libsched.so.1 => /usr/lib/libsched.so.1
libgen.so.1 => /usr/lib/libgen.so.1
libsocket.so.1 => /usr/lib/libsocket.so.1
libnsl.so.1 => /usr/lib/libnsl.so.1
libmysqlclient.so.10 =>
/usr/local/mysql/lib/mysql/libmysqlclient.so.10
libldapssl41.so =>
/export/apps/software_orig/ldap_stuff/ldapsdk_411/lib/libldapssl41.so
libplds3.so =>
/export/apps/software_orig/ldap_stuff/ldapsdk_411/lib/libplds3.so
libplc3.so =>
/export/apps/software_orig/ldap_stuff/ldapsdk_411/lib/libplc3.so
libnspr3.so =>
/export/apps/software_orig/ldap_stuff/ldapsdk_411/lib/libnspr3.so
libcrypt_i.so.1 => /usr/lib/libcrypt_i.so.1
libresolv.so.2 => /usr/lib/libresolv.so.2
libm.so.1 => /usr/lib/libm.so.1
libclntsh.so.8.0 => /export/apps/oracle/lib/libclntsh.so.8.0
libc.so.1 => /usr/lib/libc.so.1
libmp.so.2 => /usr/lib/libmp.so.2
libthread.so.1 => /usr/lib/libthread.so.1
libposix4.so.1 => /usr/lib/libposix4.so.1
libpthread.so.1 => /usr/lib/libpthread.so.1
libjava.so =>
/export/apps/oracle/JRE/lib/sparc/native_threads/libjava.so
libwtc8.so => /export/apps/oracle/lib/libwtc8.so
libaio.so.1 => /usr/lib/libaio.so.1
/usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1
#
Configure line
./configure --with-apxs=/export/apps/apache/bin/apxs
--with-oci8=/export/apps/oracle --with-mysql=/usr/local/mysql
--with-ldap=../../ldap_stuff/ldapsdk_411
--
Edit bug report at http://bugs.php.net/?id=18567&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=18567&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=18567&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=18567&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=18567&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=18567&r=support
Expected behavior: http://bugs.php.net/fix.php?id=18567&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=18567&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=18567&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=18567&r=globals