Bug #18570 Updated: Cannot load apache/libexec/libphp4.so into server: SGI compiler.

From: Date: Fri, 26 Jul 2002 00:02:00 +0000
Subject: Bug #18570 Updated: Cannot load apache/libexec/libphp4.so into server: SGI compiler.
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-15249@lists.php.net to get a copy of this message
ID: 18570 Updated by: sniper@php.net Reported By: dale@creatureworks.com Status: Closed Bug Type: Apache related Operating System: IRIX 6.5 PHP Version: 4.2.2 New Comment: Try newer snapshot, the change might not have been in that snapshot yet. Previous Comments: ------------------------------------------------------------------------ [2002-07-25 15:45:26] dale@creatureworks.com The work around... disabling IPv6 manually in main/php_config.h and doing a "make clean; make". did not fix the problem. (Disabled by #define HAVE_IPV6 0) Doing a fresh install of the latest from snaps.php.net (php4-STABLE-200207250900) also did not fix the problem. I even tried disabling IPV6 (after ./configure ) in the php4-STABLE-200207250900. In all instances I ... rm /webdev/apache/libexec/libphp4.so make clean make make install I still get... /webdev/apache/bin/apachectl start Syntax error on line 205 of /webdev/apache/conf/httpd.conf: Cannot load /webdev/apache/libexec/libphp4.so into server: 151728:/webdev/apache/bin/httpd: rld: Fatal Error: unresolvable symbol in /webdev/apache/libexec/libphp4.so: in6addr_any /webdev/apache/bin/apachectl start: httpd could not be started ------------------------------------------------------------------------ [2002-07-25 13:39:36] sniper@php.net This bug has been fixed in CVS. You can grab a snapshot of the CVS version at http://snaps.php.net/. In case this was a documentation problem, the fix will show up soon at http://www.php.net/manual/. In case this was a PHP.net website problem, the change will show up on the PHP.net site and on the mirror sites. Thank you for the report, and for helping us make PHP better. Patch merged. ------------------------------------------------------------------------ [2002-07-25 13:31:03] markonen@php.net This patch by Sascha needs to be MFH'd to fix this on the 4.2 branch: http://cvs.php.net/diff.php/php4/configure.in?r1=1.342&r2= 1.343&ty=u (ie. it is already fixed in 4.3.0-dev) Dale, you can work around this on the interim by disabling IPv6 manually in main/php_config.h and doing a "make clean; make". ------------------------------------------------------------------------ [2002-07-25 13:16:50] dale@creatureworks.com apachectl start Cannot load /webdev/apache/libexec/libphp4.so into server: 121014: /webdev/apache/bin/httpd: rld: Fatal Error: unresolvable symbol in /webdev/apache/libexec/libphp4.so: in6addr_any php-4.2.2 ./configure --with-mysql --with-apxs=/webdev/apache/bin/apxs apache_1.3.24 ./configure --prefix=/webdev/apache --enable-module=so SGI MIPSpro Compilers: Version 7.2.1 IRIX 6.5 As per similar bug report, tried changing php_config.h #define inline __inline to #define inline and recompiled. Still won't load. Same problem. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18570&edit=1

« previous php.bugs (#15249) next »