Bug #52376 [Opn->Fbk]: opendir() cannot open UNC paths in IIS7 using passthrough auth.
| From: | pajoye@php.net | Date: | Mon, 19 Jul 2010 21:50:21 +0000 |
| Subject: | Bug #52376 [Opn->Fbk]: opendir() cannot open UNC paths in IIS7 using passthrough auth. | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-152532@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=52376&edit=1
ID: 52376
Updated by: pajoye@php.net
Reported by: ryan at kisc dot edu dot np
Summary: opendir() cannot open UNC paths in IIS7 using
passthrough auth.
-Status: Open
+Status: Feedback
Type: Bug
Package: *Directory/Filesystem functions
Operating System: win64 - W2008R2
PHP Version: 5.3.2
-Assigned To:
+Assigned To: pajoye
New Comment:
Can you try to follow the advice here please:
http://support.microsoft.com/kb/214806
Previous Comments:
------------------------------------------------------------------------
[2010-07-19 12:38:30] ryan at kisc dot edu dot np
Description:
------------
This seems to be identical to #50542 but that one was closed and I
couldn't do anything to it.
Basically it was marked closed because with passthrough-authentication
essentially disabled by putting a username in "physical path
credentials" and selecting ClearText in the "Physical Path Credentials
Logon Type" both in advanced settings, this can be made to work so long
as that configuration is acceptable.
I too am having trouble with this and unfortunately the solution of
editing
physical path credentials breaks the pass through authentication to the
database, ldap, and other things. This all worked on 5.3.1 with IIS6 on
W2K3 but
on IIS7 with W2K8R2 no joy. So I upgraded to 5.3.2, still no joy. My
application is so reliant on the pass-through authentication that when I
do arrange things such that opendir works (clear-text + specific
physical path credentials) the system becomes a single user system!
So I can confirm the workaround mentioned for #50542 works if the
environment allows for it, but mine does not. Any other ideas? If I
connect to IIS using the environment requirement of network type auth
and pass-through authentication it does NOT work, though it really
should. If I use that exact same user in the "physical path credentials"
field and set "clear text" opendir suddenly works. Please don't close
this as it really is a bug and apparently specific to IIS7
Test script:
---------------
<?PHP
error_reporting(E_ALL);
opendir("any UNC path at all"); //example
//someserver/someshare/somefolder
?>
Expected result:
----------------
I expect to get no errors.
Actual result:
--------------
Warning:
opendir(//someserver/someshare/somefolder,//someserver/someshare/somefolder)
[function.opendir]: Access is denied. (code: 5) in
C:\inetpub\wwwroot\testdir.php on line 2
Warning: opendir(//someserver/someshare/somefolder) [function.opendir]:
failed to open dir: No such file or directory in
C:\inetpub\wwwroot\testdir.php on line 2
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=52376&edit=1