Bug #43990 [Com]: session_start() - failed: Permission denied (13)
| From: | vinko dot culjak at live dot com | Date: | Sat, 21 Aug 2010 01:48:03 +0000 |
| Subject: | Bug #43990 [Com]: session_start() - failed: Permission denied (13) | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-153680@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=43990&edit=1
ID: 43990
Comment by: vinko dot culjak at live dot com
Reported by: antonprk at mail dot ru
Summary: session_start() - failed: Permission denied (13)
Status: No Feedback
Type: Bug
Package: Session related
Operating System: Linux
PHP Version: 5.2.5
Assigned To: jani
Block user comment: N
New Comment:
Apache version: 2.2.15
PHP version: 5.2.13
Situation:
----------
2 websites on the same server (on a Linux Multiple Domain Reseller
Hosting plan) that both contain <?php session_start(); ?>
How to reproduce error:
-----------------------
1. Completely close your browser
2. Open your browser
3. Visit the first website (beach1.sibername.com/~dilletpr)
4. Visit the second website (beach1.sibername.com/~duroinmo) (the error
should appear on this site)
5. Completely close your browser
6. Open your browser
7. Visit the second website (beach1.sibername.com/~duroinmo)
8. Visit the first website (beach1.sibername.com/~dilletpr) (the error
should appear on this site)
Summery:
--------
The session_start() - failed: Permission denied (13) error appears when
you visit the second of 2 websites that are on the same server. If you
visit even more websites on the same server, they all have the error
except the first one.
Previous Comments:
------------------------------------------------------------------------
[2008-03-25 01:00:00] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2008-03-17 20:57:23] jani@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.2-latest.tar.gz
For Windows (zip):
http://snaps.php.net/win32/php5.2-win32-latest.zip
For Windows (installer):
http://snaps.php.net/win32/php5.2-win32-installer-latest.msi
------------------------------------------------------------------------
[2008-03-17 04:06:24] antonprk at mail dot ru
The problem is present at version PHP 5.2.4, 5.2.5
------------------------------------------------------------------------
[2008-01-31 04:30:50] antonprk at mail dot ru
Description:
------------
In PHP 4.4.4, 4.4.7, 4.4.8, on a server more than 200 users at which
periodically arise the specified error.
In php.ini add an option the name of a file of session.
2008-01-31 05:33:36 Warning(2): Unknown():
open(/tmp/sess_842bfb761b488cb7c0df711a162f6b56, O_RDWR) failed:
Permission denied (13) in /home/USER_ONE/lib/session.inc (/eng.php) on
line 24
root@server [/tmp]# ls -l --full-time
sess_842bfb761b488cb7c0df711a162f6b56
-rw------- 1 USER_TWO USER_TWO 46 2008-01-31 05:33:26.000000000 +0300
sess_842bfb761b488cb7c0df711a162f6b56
Two different users try to use one file of session.
Reproduce code:
---------------
USER_ONE
<?php
session_start();
?>
USER_TWO
<?php
session_start();
?>
Expected result:
----------------
Creation of not existing file of session was expected.
Actual result:
--------------
Attempt of creation of already existing file of session.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=43990&edit=1